summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2018-01-19 10:36:50 -0800
committerBrian Dolbec <dolsen@gentoo.org>2018-01-19 14:55:33 -0800
commite493ad3869ec78e713a1b5ad0897593a67c04de8 (patch)
tree834aebca3527a55b97da0e7c1ceaf1b43aa617ba /dev-python/spark-parser
parentdev-python/pynacl: Version bump (diff)
downloadgentoo-e493ad3869ec78e713a1b5ad0897593a67c04de8.tar.gz
gentoo-e493ad3869ec78e713a1b5ad0897593a67c04de8.tar.bz2
gentoo-e493ad3869ec78e713a1b5ad0897593a67c04de8.zip
dev-python/spark-parser: Version bump
Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-python/spark-parser')
-rw-r--r--dev-python/spark-parser/Manifest1
-rw-r--r--dev-python/spark-parser/spark-parser-1.8.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/spark-parser/Manifest b/dev-python/spark-parser/Manifest
index 6c4c412125f5..5b2199c9d57b 100644
--- a/dev-python/spark-parser/Manifest
+++ b/dev-python/spark-parser/Manifest
@@ -1,3 +1,4 @@
DIST spark_parser-1.5.1.tar.gz 111933 BLAKE2B 2ad1045f17ddc2f8fc025ca7b1567db56ce519714b59374b4653d5bfc504d12192d9c6696fc7ff8fee8ef9fc4328fb629b6cd72d8d235f8187780dadef3c9039 SHA512 d46e4bf27b867e7e20e5d9d226d606428cc2173afdca27d5f8d26db2515a7ecb89b7a27cb091ff3d7d7c9cde748cc0e027b1f9212a2fc7b75144e156d16c8916
DIST spark_parser-1.6.0.tar.gz 133871 BLAKE2B a7c57d77aa81430365c7e1156f35535b923e5f326adbffc4a7ddd2c270ce70749615ff94723825ffc0195c8d266ccf26e9e75c68b7bfdbe31e27210ab528c826 SHA512 56a89114b35449f0bcd34e2d8c6363d249b839395827fde791c0ec2e425f75a5e5e48d960a5a3c115ca4c7088ea720aba1be03c8b55611d14b18d07f9873a91c
DIST spark_parser-1.6.1.tar.gz 134114 BLAKE2B ec59af20c84e488a3211cc2d8ece8e89a70bacf52c0b3a28c78cd535fe33d5bcae45e86ee6da7e7b68c95782d1b79577a186a140f76b2255720f7bd7337dc161 SHA512 290069ebe37aa4d5dddacefe3a4d48607076990fe1f27f914d154fa48a5249cddd0c9d238b7e4c7a9a52ddfc054a3cd5639e52b618b5f4bc5b833c4e38b21c2b
+DIST spark_parser-1.8.5.tar.gz 123974 BLAKE2B 29efbeb35592bdd95108b5289448a6530f3211b31afa32dbb66721d1d473c1a30abc8f4700a6dee6f9dfc47cdfb1de036fa9fdb4c783d7bed7274d29b69a2038 SHA512 12ca0ae14c39edb825067574931b005f85eb46ac2cfc8e2573169da1fb54b4247181b9d2cc8449ab9a0dbd45742d68e415fd766764ce708df620bd7288b18130
diff --git a/dev-python/spark-parser/spark-parser-1.8.5.ebuild b/dev-python/spark-parser/spark-parser-1.8.5.ebuild
new file mode 100644
index 000000000000..fc4444683ff2
--- /dev/null
+++ b/dev-python/spark-parser/spark-parser-1.8.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1
+
+MY_PN="spark_parser"
+
+DESCRIPTION="An Early-Algorithm Context-free grammar Parser"
+HOMEPAGE="https://github.com/rocky/python-spark/ https://pypi.python.org/pypi/spark_parser"
+SRC_URI="mirror://pypi/${P:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_test() {
+ emake check
+}