summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-19 06:09:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-19 06:27:50 +0200
commit2c592ed7954c93dbcca66a4391026f4a6339047b (patch)
tree1f363e2ab12cf2a72db38d14869e887ce1cfd10f /dev-python/sphinx-autodoc-typehints
parentdev-python/sphinx-autodoc-typehints: Remove old (diff)
downloadgentoo-2c592ed7954c93dbcca66a4391026f4a6339047b.tar.gz
gentoo-2c592ed7954c93dbcca66a4391026f4a6339047b.tar.bz2
gentoo-2c592ed7954c93dbcca66a4391026f4a6339047b.zip
dev-python/sphinx-autodoc-typehints: Bump to 2.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-autodoc-typehints')
-rw-r--r--dev-python/sphinx-autodoc-typehints/Manifest1
-rw-r--r--dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.4.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-autodoc-typehints/Manifest b/dev-python/sphinx-autodoc-typehints/Manifest
index 2f5ea6114ab4..625da3312fba 100644
--- a/dev-python/sphinx-autodoc-typehints/Manifest
+++ b/dev-python/sphinx-autodoc-typehints/Manifest
@@ -1,3 +1,4 @@
DIST sphinx_autodoc_typehints-2.2.3.tar.gz 40394 BLAKE2B eece3fd99898bf6c93561b0269a7cae2d9b5bd7868ef3d9cd61868b57b9435ef255731db7fdbde2cf05b1f1ed1c8864060fd15ad5b44bbd122f2c2d4fd264aeb SHA512 8a39129ae3e90703c7de8d25c7616256b4d203f6e3c6971f382265361236e7606fa16169e189ca47cd4f1dfdf27a98a16c7b92ce409e2431886e4dacd0159fcf
DIST sphinx_autodoc_typehints-2.3.0.tar.gz 40709 BLAKE2B ef1b606cf6a643f87271fb033bac4d06f83b2be9f73b765064757ff0c1dceb2124841b2f6bb674deb20e39a4d19386fea8c85f0cdb417eeb3d84da19e2bf609e SHA512 f4ee3e0eb51fd63d4cf31f2eed9b9d06cc2dc48a3f3427763e86dba8910ea02c9e31bd8d30e8d0b3494e71fb104d51904400ce96d71270e1e422f44a317de80a
DIST sphinx_autodoc_typehints-2.4.3.tar.gz 40572 BLAKE2B 25d9f35a6b697cf99264bb48394034a546b48374edfecdd877f3b43ce00deb6b9e6581a8a9cd1b4b9342840dd702bc52c24554f39a6f828e27bb576eb3812996 SHA512 eb809df1ed8658bfb33c437417b16888636e89062ba56738dd6f0330bbf090b2ea8f98f6f5611f0c5545e024df66b7739f23aab8bbad2ee70a923ac16393310c
+DIST sphinx_autodoc_typehints-2.4.4.tar.gz 40572 BLAKE2B 2981d3adb45c7c0bc8ec81d67e26aca302ed5e6a142c36a49fe73197a4aadb91c901f185102757953a1f95ca523cf3a44d7d1a4be2c79651e8f6f8b7a882d0fa SHA512 770145187db71775833a403ebff1ed05e9db81ac0af0c0507f40fdbde5b8d5a4bd298b882ba7c8f45c083d270e82d4a6a3e27c70514dbbd3d2045ec9ba0d20fb
diff --git a/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.4.ebuild b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.4.ebuild
new file mode 100644
index 000000000000..e938bae4f916
--- /dev/null
+++ b/dev-python/sphinx-autodoc-typehints/sphinx-autodoc-typehints-2.4.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Type hints support for the Sphinx autodoc extension"
+HOMEPAGE="
+ https://github.com/tox-dev/sphinx-autodoc-typehints/
+ https://pypi.org/project/sphinx-autodoc-typehints/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/sphinx-7.1.2[${PYTHON_USEDEP}]
+"
+# skipping optional test dep on dev-python/nptyping as that package
+# is horribly broken and on its way out
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/sphobjinv-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # this package is addicted to Internet
+ tests/test_sphinx_autodoc_typehints.py::test_format_annotation
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}