summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-11 11:26:43 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-11 11:59:07 +0200
commit389c89d2bb06946816efe75ffef35d4654737968 (patch)
tree1eaf7c94fc0f51e452f0a2784a1e4a94a67ba59f /dev-python/sphinx-basic-ng
parentdev-python/pyhamcrest: Bump to 2.0.4 (diff)
downloadgentoo-389c89d2bb06946816efe75ffef35d4654737968.tar.gz
gentoo-389c89d2bb06946816efe75ffef35d4654737968.tar.bz2
gentoo-389c89d2bb06946816efe75ffef35d4654737968.zip
dev-python/sphinx-basic-ng: Bump to 0.0.1_alpha12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-basic-ng')
-rw-r--r--dev-python/sphinx-basic-ng/Manifest1
-rw-r--r--dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/sphinx-basic-ng/Manifest b/dev-python/sphinx-basic-ng/Manifest
index 8d370c8ca62b..9a3af7557b6c 100644
--- a/dev-python/sphinx-basic-ng/Manifest
+++ b/dev-python/sphinx-basic-ng/Manifest
@@ -1 +1,2 @@
DIST sphinx-basic-ng-0.0.1.a11.gh.tar.gz 21539 BLAKE2B 31707bc8f3c6cd0c1af1aeff309543889119d33e5f5ae33194b58f88a0ff6ec424c5b876fef36b64161932ebb69c0f6108801697b49d47e10ad13affcf89e1fa SHA512 e9f9278a360d2c8d25a6679134d2d54b37c9f2e55285592fa910c85b2f8bfd4ab13d117b7078cb67d862703f8054c3d3a3ca68152551d67a26d7c1a8b75952ff
+DIST sphinx-basic-ng-0.0.1.a12.gh.tar.gz 23821 BLAKE2B 905186227d725d6f62c0f4c5b4df49ada8817dd44a4000b23b62e60ce5ca3bef4a4046c9543a07a7b0cc0c12dd5278dc783633324fbe113cf453ee540fa97ff7 SHA512 6df9445306b27ae4b29b338773fa4adcee631b4be04fdde674855dfcb683f7cf7ad3c40124c85353608b63523738b6bc83c6c4f4b2b212cafa41d38462ffcac4
diff --git a/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
new file mode 100644
index 000000000000..e6f2a27ae78a
--- /dev/null
+++ b/dev-python/sphinx-basic-ng/sphinx-basic-ng-0.0.1_alpha12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_alpha/.a}
+DESCRIPTION="A modern skeleton for Sphinx themes"
+HOMEPAGE="
+ https://github.com/pradyunsg/sphinx-basic-ng/
+ https://pypi.org/project/sphinx-basic-ng/
+"
+SRC_URI="
+ https://github.com/pradyunsg/sphinx-basic-ng/archive/${PV/_alpha/.a}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/sphinx-6[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ local HTML_DOCS=()
+ build_sphinx tests/barebones
+ rm -r tests/barebones/_build || die
+}