summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-02 11:07:02 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-02 11:07:02 -0400
commit9aa5534ef256dbd78fdfd3efaeeaf0766d5a3d3f (patch)
tree686d84e774bfaf81213e5eb40b22c789902d7448 /dev-python/sphinx-gallery
parentgames-strategy/widelands: Removed old. (diff)
downloadgentoo-9aa5534ef256dbd78fdfd3efaeeaf0766d5a3d3f.tar.gz
gentoo-9aa5534ef256dbd78fdfd3efaeeaf0766d5a3d3f.tar.bz2
gentoo-9aa5534ef256dbd78fdfd3efaeeaf0766d5a3d3f.zip
dev-python/sphinx-gallery: bump to 0.3.1
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/sphinx-gallery')
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 3ba64540a9a5..9c77faaef24c 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1 +1,2 @@
DIST sphinx-gallery-0.1.12.tar.gz 68976 BLAKE2B c9f8f12f775df8cac0f0ad7d70b0dd099dacb3b005584d1bbc878437443144d7e2613ceecd25cd4b0c8941818c5596f6435c1fa223b1e5c5d5196827a69163fb SHA512 57e8fc3746c2f5c941ddc3e00c749a6bfa63fb5741b3e5551df02f798858c417acee05a6b35512506aa0c4866b14a093cb4269284501672c3bbbf2edfc1edc1d
+DIST sphinx-gallery-0.3.1.tar.gz 88807 BLAKE2B 79218a1f438e2b8607c52b14f098c0136cb4d5ce15a12d82bdb3caf0c7c1090e7c4f210437fc660d8d4d19bf87bbaa2ec3c208d2dc8a77ad9deea5b5cefa3c05 SHA512 c51eaaef63a7496e223a4541d0560f694420b6ac4b2cde3779c405f0ab92d34aef7a37e4c41da9e59bd8a050c8d3eed330df3799e76a60ae35cdbc6f7c9cb8c1
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild
new file mode 100644
index 000000000000..4f1ae7b02a29
--- /dev/null
+++ b/dev-python/sphinx-gallery/sphinx-gallery-0.3.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
+HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# tests need extra files not distributed