summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-12 12:04:15 +0200
committerDavid Seifert <soap@gentoo.org>2019-09-12 12:04:15 +0200
commit9ced40ed7bbfddd48cc772b6de33e2e6b92e32cd (patch)
treeec2c800b61564517d9fb0ee142cba280a199523f /dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
parentdev-python/mediafile: new package (0.2.0) (diff)
downloadgentoo-9ced40ed7bbfddd48cc772b6de33e2e6b92e32cd.tar.gz
gentoo-9ced40ed7bbfddd48cc772b6de33e2e6b92e32cd.tar.bz2
gentoo-9ced40ed7bbfddd48cc772b6de33e2e6b92e32cd.zip
dev-python/sphinxcontrib-pretty-searchresults: new package (0.3.5)
Decently styled search results for sphinx-doc projects. Closes: https://bugs.gentoo.org/693168 Closes: https://github.com/gentoo/gentoo/pull/12826 Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild')
-rw-r--r--dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild b/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
new file mode 100644
index 000000000000..93849564786c
--- /dev/null
+++ b/dev-python/sphinxcontrib-pretty-searchresults/sphinxcontrib-pretty-searchresults-0.3.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN/sphinxcontrib/sphinx}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Decently styled search results for sphinx-doc projects"
+HOMEPAGE="https://github.com/sphinx-contrib/sphinx-pretty-searchresults"
+SRC_URI="https://github.com/sphinx-contrib/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx-testing[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" run.py || die
+}