summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 06:47:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 07:05:28 +0200
commit7cbd2234cc6071c30e0c30a18f5acb33e45c8b3e (patch)
tree115c823766a81cfc568b85e5a2d6bbf5c880f459 /dev-python/structlog
parentdev-python/python-lsp-server: Bump to 1.8.2 (diff)
downloadgentoo-7cbd2234cc6071c30e0c30a18f5acb33e45c8b3e.tar.gz
gentoo-7cbd2234cc6071c30e0c30a18f5acb33e45c8b3e.tar.bz2
gentoo-7cbd2234cc6071c30e0c30a18f5acb33e45c8b3e.zip
dev-python/structlog: Bump to 23.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/structlog')
-rw-r--r--dev-python/structlog/Manifest1
-rw-r--r--dev-python/structlog/structlog-23.2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/structlog/Manifest b/dev-python/structlog/Manifest
index 1cf56c903ebc..60c4fb662edf 100644
--- a/dev-python/structlog/Manifest
+++ b/dev-python/structlog/Manifest
@@ -1 +1,2 @@
DIST structlog-23.1.0.tar.gz 746300 BLAKE2B 94e6099729803fff717c24922f90be0484f045e4fe231398242a890e6e18359f9a5c231985818d655141e978fe06546f36540a96ebe332f5bbf6d5500fc111c0 SHA512 24e28791e12a4a106062368771385ac06e80bd50fb051d2a71205cf9e6ebf92ca8a4e6c0efefd8d862699ac8dee9b4d1ccf4ee33f8d76233acf5256d69f9593c
+DIST structlog-23.2.0.tar.gz 749288 BLAKE2B c5a619ddacc04e6f2377c66aa343ecfddb8001d5d87c3f10859c2644ce427150771abe4942d57a9ea6db1029af5bde825a0a99218921beea08c4fd147fc5c1cb SHA512 01ddaf3b819da66beefef1810e6d460a2e5ce37f6be3dee144411a3a5db7c81bdfd83a0843172a921406596a2b9f1f87de08caf881c7d701496825203d13bdad
diff --git a/dev-python/structlog/structlog-23.2.0.ebuild b/dev-python/structlog/structlog-23.2.0.ebuild
new file mode 100644
index 000000000000..c63e9ed46965
--- /dev/null
+++ b/dev-python/structlog/structlog-23.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Structured Logging for Python"
+HOMEPAGE="
+ https://github.com/hynek/structlog/
+ https://pypi.org/project/structlog/
+"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~riscv ~x86"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest