summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-09-21 14:23:23 +0100
committerMarek Szuba <marecki@gentoo.org>2022-09-21 15:00:04 +0100
commitbc02e16fabc12a287f4beb0c628218458ca1d67a (patch)
tree34f8f3b3090c28222405fec35a357ae9c1326c98 /dev-python/subprocess-tee
parentdev-python/enrich: enable py3.11 (diff)
downloadgentoo-bc02e16fabc12a287f4beb0c628218458ca1d67a.tar.gz
gentoo-bc02e16fabc12a287f4beb0c628218458ca1d67a.tar.bz2
gentoo-bc02e16fabc12a287f4beb0c628218458ca1d67a.zip
dev-python/subprocess-tee: skip tests triggering issues with dev-python/enrich
Closes: https://bugs.gentoo.org/866051 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/subprocess-tee')
-rw-r--r--dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
index ea05ad858dc4..07ec6f767cea 100644
--- a/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
+++ b/dev-python/subprocess-tee/subprocess-tee-0.3.5.ebuild
@@ -24,11 +24,17 @@ BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]
test-full? ( app-admin/ansible-molecule )
)"
+# With the exception of a handful of extra lines this is literally the same test suite
+# as test_console.py from dev-python/enrich, which is currently known to fail (Bug #865497).
+EPYTEST_DESELECT=(
+ src/subprocess_tee/test/test_rich.py
+)
+
distutils_enable_tests pytest
python_test() {
if ! use test-full; then
- local -x EPYTEST_DESELECT=( "src/${PN/-/_}/test/test_func.py::test_molecule" )
+ EPYTEST_DESELECT+=( "src/${PN/-/_}/test/test_func.py::test_molecule" )
fi
distutils-r1_python_test
}