summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-07-31 20:34:23 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-07-31 21:20:23 +0300
commitc1c0ee45fa88182109a719870aca43d2f18eb549 (patch)
treed1f7b54efc60f85947492dccfeca8a23c32b8e82 /dev-python/tcolorpy
parentdev-python/inflect: add 6.0.0, disable py3.11 (diff)
downloadgentoo-c1c0ee45fa88182109a719870aca43d2f18eb549.tar.gz
gentoo-c1c0ee45fa88182109a719870aca43d2f18eb549.tar.bz2
gentoo-c1c0ee45fa88182109a719870aca43d2f18eb549.zip
dev-python/tcolorpy: Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/tcolorpy')
-rw-r--r--dev-python/tcolorpy/tcolorpy-0.1.2-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/tcolorpy/tcolorpy-0.1.2-r1.ebuild b/dev-python/tcolorpy/tcolorpy-0.1.2-r1.ebuild
new file mode 100644
index 000000000000..cdd2418bc6ae
--- /dev/null
+++ b/dev-python/tcolorpy/tcolorpy-0.1.2-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="tcolorpy is a Python library to apply true color for terminal text"
+HOMEPAGE="https://github.com/thombashi/tcolorpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest