summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-25 11:37:16 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-25 13:34:47 +0100
commitfe989d0b7d41c6f17038174b776546a373a5f91a (patch)
treef8d98520d049be02b0d32acb5ea8a2da3a8c258a /dev-python/tempest-lib/tempest-lib-1.0.0-r1.ebuild
parentdev-python/python-troveclient: dev-python/sphinx is not a test dep (diff)
downloadgentoo-fe989d0b7d41c6f17038174b776546a373a5f91a.tar.gz
gentoo-fe989d0b7d41c6f17038174b776546a373a5f91a.tar.bz2
gentoo-fe989d0b7d41c6f17038174b776546a373a5f91a.zip
dev-python/tempest-lib: dev-python/sphinx is not a test dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tempest-lib/tempest-lib-1.0.0-r1.ebuild')
-rw-r--r--dev-python/tempest-lib/tempest-lib-1.0.0-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/tempest-lib/tempest-lib-1.0.0-r1.ebuild b/dev-python/tempest-lib/tempest-lib-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..afc3e7401935
--- /dev/null
+++ b/dev-python/tempest-lib/tempest-lib-1.0.0-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Functional or integrated test suites for OpenStack projects"
+HOMEPAGE="https://pypi.org/project/tempest-lib/ https://github.com/openstack/tempest-lib"
+SRC_URI="mirror://pypi/t/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/jsonschema-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/os-testr-0.4.1[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( ${RDEPEND}
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/ddt-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-0.1.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tempest_lib/tests || die "Tests fail with ${EPYTHON}"
+}