summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 08:53:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 09:02:26 +0100
commita3ffc021b679bd8793b0ab369876372142be9fdf (patch)
tree353b39fbabdb9e682d4023cb72025f2d5899d0bd /dev-python/texttable/texttable-1.6.7.ebuild
parentnet-misc/rsync: add rrsync USE flag (diff)
downloadgentoo-a3ffc021b679bd8793b0ab369876372142be9fdf.tar.gz
gentoo-a3ffc021b679bd8793b0ab369876372142be9fdf.tar.bz2
gentoo-a3ffc021b679bd8793b0ab369876372142be9fdf.zip
dev-python/texttable: Bump to 1.6.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/texttable/texttable-1.6.7.ebuild')
-rw-r--r--dev-python/texttable/texttable-1.6.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/texttable/texttable-1.6.7.ebuild b/dev-python/texttable/texttable-1.6.7.ebuild
new file mode 100644
index 000000000000..a67b50ccc120
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module to create simple ASCII tables"
+HOMEPAGE="
+ https://github.com/foutaise/texttable/
+ https://pypi.org/project/texttable/
+"
+SRC_URI="
+ https://github.com/foutaise/texttable/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}
+
+pkg_postinst() {
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}