summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-08 06:57:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-08 07:12:21 +0200
commite6b100f6a68fed06ff71183beb8b4446ba7e881b (patch)
treec3c5b59f741b51f8f778433f95a6ef24950d7c5f /dev-python/towncrier
parentdev-python/sphinx-rtd-theme: Bump to 1.2.2 (diff)
downloadgentoo-e6b100f6a68fed06ff71183beb8b4446ba7e881b.tar.gz
gentoo-e6b100f6a68fed06ff71183beb8b4446ba7e881b.tar.bz2
gentoo-e6b100f6a68fed06ff71183beb8b4446ba7e881b.zip
dev-python/towncrier: Bump to 23.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/towncrier')
-rw-r--r--dev-python/towncrier/Manifest1
-rw-r--r--dev-python/towncrier/towncrier-23.6.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/towncrier/Manifest b/dev-python/towncrier/Manifest
index 35e0762bd80d..e5d9f008d5de 100644
--- a/dev-python/towncrier/Manifest
+++ b/dev-python/towncrier/Manifest
@@ -1 +1,2 @@
DIST towncrier-22.12.0.gh.tar.gz 54670 BLAKE2B b6baf6970cc8a5f798f378ae7c0637184a869c3c72907205c6493786353f1a5f26e1bca0faa7f4685236e3a1fc9d4b2cfe6632f01d36926ae9e74cb188460674 SHA512 6fad515b2368f2c1ee27673080607460949d6651d3c9b9ab106b8e7f0298d0748a4ec1424f73bb7bf8a81eef5b0fa74de6a0b7295f02f02f354f20a99eb30814
+DIST towncrier-23.6.0.gh.tar.gz 59311 BLAKE2B d778154288923aa26c8d4d99b5f4c999ce50687164c4477d093b1254394ed7cbc5d708f1a1b7e6f25ebca95217a049692f7c9ee822661f44d02f79db32240229 SHA512 44142130b6a3e4428a085f1c6e793ccf631de77f8f2eafb8d1145f45d8d26faa6d27c30f09b8db95e63b4c3de927ac975ed95d1ed6b76dac3d9ba5eef54989c0
diff --git a/dev-python/towncrier/towncrier-23.6.0.ebuild b/dev-python/towncrier/towncrier-23.6.0.ebuild
new file mode 100644
index 000000000000..c2ceb8e19d71
--- /dev/null
+++ b/dev-python/towncrier/towncrier-23.6.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building newsfiles for your project"
+HOMEPAGE="
+ https://github.com/twisted/towncrier/
+ https://pypi.org/project/towncrier/
+"
+SRC_URI="
+ https://github.com/twisted/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/click-default-group[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/incremental[${PYTHON_USEDEP}]
+ test? (
+ dev-vcs/git
+ >=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial towncrier ||
+ die "tests failed with ${EPYTHON}"
+}