summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-22 17:58:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-22 18:00:34 +0200
commitfdb449e120eb70d2f23ca1e13ce5da3adb4677f7 (patch)
treeb3de0a94821dc6ace4f0d9b12aa1d88d7041bd8e /dev-python/translate-toolkit
parentdev-python/tempest: Remove old (diff)
downloadgentoo-fdb449e120eb70d2f23ca1e13ce5da3adb4677f7.tar.gz
gentoo-fdb449e120eb70d2f23ca1e13ce5da3adb4677f7.tar.bz2
gentoo-fdb449e120eb70d2f23ca1e13ce5da3adb4677f7.zip
dev-python/translate-toolkit: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest1
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild98
2 files changed, 0 insertions, 99 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index 3bd6ad67f8ec..b5b86e49e01c 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,2 +1 @@
-DIST translate-3.7.2.gh.tar.gz 1153306 BLAKE2B 986c531004cb0ee0a58a940043377ee047e13b0f32c6fda5ab80cc7fca96d18b45f2cd3e112d47f177cd06a7e99580777c6591df969a8237bcb9fe7a52b1d4fd SHA512 28d774ff670c92dedee5d98d7d33f21d32ed4b7afd6a8281fcf7abb39470e11a6c0d9c121576aa2be10edf18929c74b2cfc36b70984d66d432cfa5e337b9556c
DIST translate-3.7.3.gh.tar.gz 1153916 BLAKE2B 476b8ca3fd277f56cc73d8fc8f5adbf9ddb442b404c586627cc91af228ae08bbb87310219c910701de4938cb9977b386d0ed7b503901369a1ac5069664ebbd25 SHA512 ee339300e798fc043b1ac5455366e96bd5dab08306855a84cdcfd6d5176560366c3538810e94b7477704a5d1ed218e5c85f735979f48cd33242791ce1ad39c3b
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild
deleted file mode 100644
index c7db5dea2e22..000000000000
--- a/dev-python/translate-toolkit/translate-toolkit-3.7.2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_P=translate-${PV}
-DESCRIPTION="Toolkit to convert between many translation formats"
-HOMEPAGE="
- https://github.com/translate/translate/
- https://pypi.org/project/translate-toolkit/
-"
-SRC_URI="
- https://github.com/translate/translate/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="+html +ical +ini +subtitles +yaml"
-
-RDEPEND="
- app-text/iso-codes
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/pycountry-19.8.18[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- sys-devel/gettext
- html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
- ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
- ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
- subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
- yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? ( dev-python/phply[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-bootstrap-theme
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Fails with network-sandbox (and even with it off but w/ softer fail)
- 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
- 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
- )
- local EPYTEST_IGNORE=(
- # unpackaged fluent.*
- translate/storage/test_fluent.py
- )
-
- if ! use ini; then
- EPYTEST_IGNORE+=(
- translate/convert/test_ini2po.py
- translate/convert/test_po2ini.py
- )
- fi
-
- if ! use subtitles; then
- EPYTEST_IGNORE+=(
- translate/storage/test_subtitles.py
- )
- fi
-
- # translate/storage/test_mo.py needs 'pocompile'
- distutils_install_for_testing
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if ! use html; then
- rm "${ED}"/usr/bin/{html2po,po2html} || die
- fi
- if ! use ical; then
- rm "${ED}"/usr/bin/{ical2po,po2ical} || die
- fi
- if ! use ini; then
- rm "${ED}"/usr/bin/{ini2po,po2ini} || die
- fi
- if ! use subtitles; then
- rm "${ED}"/usr/bin/{sub2po,po2sub} || die
- fi
-
- python_optimize
-}