summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-23 04:19:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-23 04:37:07 +0100
commit5e176c207c4c74bd94b4156eb56f93c6e61b5459 (patch)
tree4725a36833ae5cfa99be8e74154cb2019f96270d /dev-python/trove-classifiers
parentdev-python/sqlglot: Bump to 21.2.1 (diff)
downloadgentoo-5e176c207c4c74bd94b4156eb56f93c6e61b5459.tar.gz
gentoo-5e176c207c4c74bd94b4156eb56f93c6e61b5459.tar.bz2
gentoo-5e176c207c4c74bd94b4156eb56f93c6e61b5459.zip
dev-python/trove-classifiers: Bump to 2024.2.22
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/trove-classifiers')
-rw-r--r--dev-python/trove-classifiers/Manifest1
-rw-r--r--dev-python/trove-classifiers/trove-classifiers-2024.2.22.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/trove-classifiers/Manifest b/dev-python/trove-classifiers/Manifest
index 551819c1743a..0f585ad84f4d 100644
--- a/dev-python/trove-classifiers/Manifest
+++ b/dev-python/trove-classifiers/Manifest
@@ -1 +1,2 @@
DIST trove-classifiers-2024.1.31.tar.gz 15958 BLAKE2B c08cd4c7a13cd1473171bb8f5ed478f649bc1083d9881e260d43a2a3fb2679cf0f7ac926af3136d593cab63266826545be35301bf4d18a0b9b2d5919a31d0b74 SHA512 b77f2a84a89a4f5ce3ee94921d7d293bd70869af53632ffc0e08a4e0e3876c5ca4e86aefef0622be3d1a2f4eb5f153f294bbec251431373d1e98418a76cf93fb
+DIST trove-classifiers-2024.2.22.tar.gz 15951 BLAKE2B 97afd582592d094a226f3deb8076b0c4bbd9b1321d57eeef4a4e45088825d23ff07102d34a5192b62f3d509de744ae923876d2b3a98513fe1305e71edc2ddab4 SHA512 efbcf87d5c197b26e7972fff2b024dc7044941cf29c61b9a652227f28590f9a4063ac3738130c94e913232828ae386967265e3d405c11a160aff9c0af888a16a
diff --git a/dev-python/trove-classifiers/trove-classifiers-2024.2.22.ebuild b/dev-python/trove-classifiers/trove-classifiers-2024.2.22.ebuild
new file mode 100644
index 000000000000..3172a692bdd9
--- /dev/null
+++ b/dev-python/trove-classifiers/trove-classifiers-2024.2.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Canonical source for classifiers on PyPI (pypi.org)"
+HOMEPAGE="
+ https://github.com/pypa/trove-classifiers/
+ https://pypi.org/project/trove-classifiers/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease hatchling bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "trove-classifiers"
+ version = "${PV}"
+ description = "Canonical source for classifiers on PyPI (pypi.org)."
+ EOF
+}
+
+python_test() {
+ epytest
+ "${EPYTHON}" -m tests.lib || die
+}