summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-05 15:21:16 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-05 15:24:18 +0100
commitca6fdbc6664d3079c3129ee4caede9973b8bbf17 (patch)
treee634be073729aac4c9b46580c4dd18323bfb401f /dev-python/tweepy
parentpackage.mask: Last rite net-im/turses (diff)
downloadgentoo-ca6fdbc6664d3079c3129ee4caede9973b8bbf17.tar.gz
gentoo-ca6fdbc6664d3079c3129ee4caede9973b8bbf17.tar.bz2
gentoo-ca6fdbc6664d3079c3129ee4caede9973b8bbf17.zip
dev-python/tweepy: Remove old (py2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tweepy')
-rw-r--r--dev-python/tweepy/Manifest1
-rw-r--r--dev-python/tweepy/tweepy-2.3.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/tweepy/Manifest b/dev-python/tweepy/Manifest
index 30347596037f..2ecd1b2ab647 100644
--- a/dev-python/tweepy/Manifest
+++ b/dev-python/tweepy/Manifest
@@ -1,2 +1 @@
-DIST tweepy-2.3.tar.gz 52352 BLAKE2B 6853f133e73d8a97d5a2326ef6c877a527fad87ba9767e6ee218efcb84f6b8332d4f66b044b572987e71d4d9dd8a7b743c7976cfa9947101f0df5c6f9de5d1c4 SHA512 23317a507174e108cf8d13232aa467d892aba1789ee4f610eef4f5503b045841b5c85e8ae63ddcfd1e07178afbf3bf9f4a9fed939426411a8566f1c949b9b831
DIST tweepy-3.5.0.tar.gz 24348 BLAKE2B ea9d96abe4f364e1f77a97ce28fcd4fca3224ab307698e59a834c20becfa53ab68851e638946085431ef2edc1a4e3bf4f42a113c2ac41561930b7f4638e5d6c4 SHA512 cf87f0b7dea0ca444c17a3fdb9c2ebef814683c110511876c1997630b3202393276d3dd2de3b37fc21eb7a15382d22cc886109bda5a11b3d06a08081704c8c2a
diff --git a/dev-python/tweepy/tweepy-2.3.ebuild b/dev-python/tweepy/tweepy-2.3.ebuild
deleted file mode 100644
index 810587b01250..000000000000
--- a/dev-python/tweepy/tweepy-2.3.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1 vcs-snapshot
-
-DESCRIPTION="A Python library for accessing the Twitter API "
-HOMEPAGE="https://www.tweepy.org/"
-SRC_URI="https://github.com/tweepy/${PN}/tarball/${PV} -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-# online tests
-RESTRICT="test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/httreplay[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Required to avoid file collisions at install
- sed \
- -e "/find_packages/s:]:,'tests.*','examples']:g" \
- -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests -v \
- tests.test_api tests.test_streaming \
- tests.test_cursors tests.test_utils || die
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}