summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-23 09:47:48 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-23 09:47:48 +0300
commit33d263f7db3711b406040ecf24adeaf23265ee98 (patch)
treec85b78072a1766f43dcc5a613484c3312bc5f36e /dev-python/utidylib
parentdev-python/phply: enable py3.10 (diff)
downloadgentoo-33d263f7db3711b406040ecf24adeaf23265ee98.tar.gz
gentoo-33d263f7db3711b406040ecf24adeaf23265ee98.tar.bz2
gentoo-33d263f7db3711b406040ecf24adeaf23265ee98.zip
dev-python/utidylib: add 0.7, enable py3.10, cleanup ebuild
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/utidylib')
-rw-r--r--dev-python/utidylib/Manifest1
-rw-r--r--dev-python/utidylib/utidylib-0.7.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/utidylib/Manifest b/dev-python/utidylib/Manifest
index c64ef0996cde..04e26a3d08e7 100644
--- a/dev-python/utidylib/Manifest
+++ b/dev-python/utidylib/Manifest
@@ -1 +1,2 @@
DIST uTidylib-0.6.tar.gz 15771 BLAKE2B 9d4fe57d985ea6e52680bd528862d3236137221227a23fe05b886d01d240e21d7159dbf7d6da3af8020009ca45c60c2297e374bb7aa05cb6b5a8eaf444710c58 SHA512 a85506ef8824f66ee326ad651020dc3b4e00190e20dcd3814984fa27ff319f492fe5bac781b7c43c8694cbfc63409e3abda18981969c9be2c3cd023fe7a4f2f8
+DIST utidylib-0.7.gh.tar.gz 15203 BLAKE2B c32f23ab3a94191423655f9b6a99bd85aca7072fcfea7507c5d4efb19c4ee22114afe136c6299e8322e15195c4f938094e49483b1a40d05522f2d232dd9a6acd SHA512 69b22671223cc9e1888a1be19b418e883baa79401bcf3856fa48cca441ae7fa414047c296f8fc9ff35aa7407901fa64cd8ddfcc56657a98e8e188073dfc72172
diff --git a/dev-python/utidylib/utidylib-0.7.ebuild b/dev-python/utidylib/utidylib-0.7.ebuild
new file mode 100644
index 000000000000..bf5039557621
--- /dev/null
+++ b/dev-python/utidylib/utidylib-0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+MY_P="uTidylib-${PV}"
+inherit distutils-r1
+
+DESCRIPTION="TidyLib Python wrapper"
+HOMEPAGE="https://cihar.com/software/utidylib/ https://pypi.org/project/uTidylib/"
+SRC_URI="https://github.com/nijel/utidylib/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="app-text/tidy-html5"
+DEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+EPYTEST_DESELECT=(
+ # https://github.com/nijel/utidylib/issues/9
+ tidy/test_tidy.py::TidyTestCase::test_missing_load
+)