summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-11 19:48:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-11 19:48:24 +0200
commit656eacdc654008eb542e88eda78d584643d3304c (patch)
tree25f4a30e03c2e2710776cc0c2f4585f70734e167 /dev-python/vcrpy
parentdev-python/testfixtures: Remove old (diff)
downloadgentoo-656eacdc654008eb542e88eda78d584643d3304c.tar.gz
gentoo-656eacdc654008eb542e88eda78d584643d3304c.tar.bz2
gentoo-656eacdc654008eb542e88eda78d584643d3304c.zip
dev-python/vcrpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest1
-rw-r--r--dev-python/vcrpy/vcrpy-1.11.1.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index e1366f948961..899e2bb966f2 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,2 +1 @@
-DIST vcrpy-1.11.1.tar.gz 63122 BLAKE2B da0fabb1eb342eb268923bcf433ac108d06fc111714834e99d9364358064ad0814bff1463f49bea60c59fe901c46fc8b78c4129e9bb4ab6736266f18b3bdf272 SHA512 d883b87d5b3017843dfc2e33241953ada27d50ffda4936ba4326a392acb9c7667474abd054d6e44b0208096cd96b68e87ec9780c0d6fab77369cc4e517617395
DIST vcrpy-4.0.2.tar.gz 324196 BLAKE2B 8910ba40bd56c7836a92c120c480e633063c78beb1d7c4dcfffb6180135cf0e28586410307ba3e19b3fa484a72a176dbf877f781ade7bae7c81110fde2eedd32 SHA512 17eebc9574ff14f97ad200b99c50b0440a93fbf38afe8ad95f443370d84c43177ac55ab655ffea7e7985b0cd76124eff3c394898e71a0ba0c434014f07e526f9
diff --git a/dev-python/vcrpy/vcrpy-1.11.1.ebuild b/dev-python/vcrpy/vcrpy-1.11.1.ebuild
deleted file mode 100644
index dd4a33310f3f..000000000000
--- a/dev-python/vcrpy/vcrpy-1.11.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Automatically mock your HTTP interactions to simplify and speed up testing"
-HOMEPAGE="https://github.com/kevin1024/vcrpy"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-#SRC_URI="https://github.com/kevin1024/vcrpy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/httplib2-0.9.1[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/six-1.5[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
- dev-python/yarl[${PYTHON_USEDEP}]
- "
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/vcrpy-skip-network-tests.patch
-)
-
-python_test() {
- py.test -vv -x tests/unit || die
-}