summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-17 04:19:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-17 04:30:58 +0100
commitbb48c49389d6614e994198bf287655ba90232184 (patch)
tree4a33085209093ed33a15afb939a9d17e9cceac24 /dev-python/versioningit
parentdev-python/djangorestframework: Bump to 3.15.0 (diff)
downloadgentoo-bb48c49389d6614e994198bf287655ba90232184.tar.gz
gentoo-bb48c49389d6614e994198bf287655ba90232184.tar.bz2
gentoo-bb48c49389d6614e994198bf287655ba90232184.zip
dev-python/versioningit: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/versioningit')
-rw-r--r--dev-python/versioningit/Manifest1
-rw-r--r--dev-python/versioningit/versioningit-3.1.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/versioningit/Manifest b/dev-python/versioningit/Manifest
index 139f4b889f72..62936285c271 100644
--- a/dev-python/versioningit/Manifest
+++ b/dev-python/versioningit/Manifest
@@ -1 +1,2 @@
DIST versioningit-3.0.0.tar.gz 203693 BLAKE2B 8253e367eea67711f2381bf6484f18b26d356c48872cb2f3b135c42c08d0e03114bfea4d02eb50e404094167609b24bab37f1bb7cc73ba877777f524e564f5db SHA512 162cbe50d22be03c20e5d6efad0672264544fa918d706cdf158b30befe429f8ba0621b664c91ccad2f13d24176f7a3a1a36a8dc2b7a0263c8585d06b4f98bc41
+DIST versioningit-3.1.0.tar.gz 215117 BLAKE2B d0fc7056cc59088ed0091bc20af540b39238ca33bc049ffb87978e48a605cbee69a2daf574ff9b3791b3d55b708adeaca877f1914b8d4d2106f76cfa33dea608 SHA512 d30ec0b2831ab3e77e51b3e41b542ef2e73838dd78a2b1bebb64db4f7fdb4c988299f7b9605c9ff884c130fe97b2491e1bb27866450346023b68dd1a2204e04d
diff --git a/dev-python/versioningit/versioningit-3.1.0.ebuild b/dev-python/versioningit/versioningit-3.1.0.ebuild
new file mode 100644
index 000000000000..105eac3c72ec
--- /dev/null
+++ b/dev-python/versioningit/versioningit-3.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A setuptools plugin for versioning based on git tags"
+HOMEPAGE="
+ https://github.com/jwodder/versioningit/
+ https://pypi.org/project/versioningit/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ <dev-python/tomli-3[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Tries to do wheel/pip installs
+ test/test_end2end.py
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}