summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-25 07:47:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-25 09:12:18 +0200
commit10480e7f95e8356be77f1202d2e7d0dfd72c792e (patch)
treefa19f2e0a95028d5b1533cc968d6a66add65c400 /dev-python/werkzeug
parentdev-python/cssutils: Bump to 2.5.1 (diff)
downloadgentoo-10480e7f95e8356be77f1202d2e7d0dfd72c792e.tar.gz
gentoo-10480e7f95e8356be77f1202d2e7d0dfd72c792e.tar.bz2
gentoo-10480e7f95e8356be77f1202d2e7d0dfd72c792e.zip
dev-python/werkzeug: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/werkzeug')
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-2.2.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index dc1f766b3057..1eca60fcf8c3 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1 +1,2 @@
DIST werkzeug-2.1.2.gh.tar.gz 833667 BLAKE2B e045f566862bfe0f86185cd10aa26bf94a4fc2f7b23173c6a28c9b55d0f239fbba5c66071fab5df6102717b51a1c1fada872e9d9383b9d3b34ab92ffcfd96e59 SHA512 28c4a794a3dbc8423e59244fbcf192b60b53f378444aaaf60330bdd62cec38a4625033b5d72b55613c8b26053a60153ddcb816331ff28ad3ee03bede74d8b1b3
+DIST werkzeug-2.2.0.gh.tar.gz 839619 BLAKE2B b6eae91d9a44d030517be5da13c448cf4a2778db7cde61ce36add8dea6f2ac251b31e71d128c4156f44083a4c1b77e546a7e6c55787d8beb93c49538d45b51fd SHA512 2de05269ccd3d83728d435d2f155887a5fd3f3bda9b71c32ffd64b089116c80e89319870fa082f1c6feeeb797b665521b9692ce6c87dcb48b7fa49b2fc63516b
diff --git a/dev-python/werkzeug/werkzeug-2.2.0.ebuild b/dev-python/werkzeug/werkzeug-2.2.0.ebuild
new file mode 100644
index 000000000000..e9c3e2214e52
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-2.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="
+ https://palletsprojects.com/p/werkzeug/
+ https://pypi.org/project/Werkzeug/
+ https://github.com/pallets/werkzeug/
+"
+SRC_URI="
+ https://github.com/pallets/werkzeug/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
+"
+# NOTE: remove the loong mask after greenlet gains support for loong
+# see https://github.com/python-greenlet/greenlet/pull/257
+BDEPEND="
+ test? (
+ dev-python/ephemeral-port-reserve[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ !alpha? ( !hppa? ( !ia64? (
+ $(python_gen_cond_dep '
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ ' python3_{8..10} pypy3 # TODO: add py3.11 when ported
+ )
+ ) ) )
+ !hppa? ( !ia64? ( !loong? (
+ $(python_gen_cond_dep '
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ ) ) )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ if ! has_version "dev-python/cryptography[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ "tests/test_serving.py::test_server[https]"
+ tests/test_serving.py::test_ssl_dev_cert
+ tests/test_serving.py::test_ssl_object
+ )
+ fi
+
+ # the default portage tempdir is too long for AF_UNIX sockets
+ local -x TMPDIR=/tmp
+ epytest -p no:django -p no:httpbin tests
+}