summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 07:57:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:34:04 +0200
commit8581c409fab86634db9530f04f7090395dde04d7 (patch)
treeac6ca3400f5edffc9a7931041a1e7ddfa94069f6 /dev-python/whisper/whisper-1.1.10.ebuild
parentdev-python/PyPDF2: Bump to 1.28.1 (diff)
downloadgentoo-8581c409fab86634db9530f04f7090395dde04d7.tar.gz
gentoo-8581c409fab86634db9530f04f7090395dde04d7.tar.bz2
gentoo-8581c409fab86634db9530f04f7090395dde04d7.zip
dev-python/whisper: Bump to 1.1.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/whisper/whisper-1.1.10.ebuild')
-rw-r--r--dev-python/whisper/whisper-1.1.10.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/whisper/whisper-1.1.10.ebuild b/dev-python/whisper/whisper-1.1.10.ebuild
new file mode 100644
index 000000000000..d587c6d47c45
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="
+ https://github.com/graphite-project/whisper/
+ https://pypi.org/project/whisper/
+"
+SRC_URI="
+ https://github.com/graphite-project/whisper/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # not a regression (fails the same with the previous version)
+ # https://github.com/graphite-project/whisper/issues/321
+ test_whisper.py::TestWhisper::test_resize_with_aggregate
+)