summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-11 13:53:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-11 13:53:18 +0200
commitdb76f30e01ccb9772a0feb291884b718e1591ebe (patch)
treec7fe98c78387e646cbb076616351465fb691ecc0 /dev-python/xmlschema/xmlschema-1.10.0.ebuild
parentdev-python/elementpath: Enable py3.11 (diff)
downloadgentoo-db76f30e01ccb9772a0feb291884b718e1591ebe.tar.gz
gentoo-db76f30e01ccb9772a0feb291884b718e1591ebe.tar.bz2
gentoo-db76f30e01ccb9772a0feb291884b718e1591ebe.zip
dev-python/xmlschema: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xmlschema/xmlschema-1.10.0.ebuild')
-rw-r--r--dev-python/xmlschema/xmlschema-1.10.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/xmlschema/xmlschema-1.10.0.ebuild b/dev-python/xmlschema/xmlschema-1.10.0.ebuild
index c8447a482d37..f3be2f731360 100644
--- a/dev-python/xmlschema/xmlschema-1.10.0.ebuild
+++ b/dev-python/xmlschema/xmlschema-1.10.0.ebuild
@@ -4,12 +4,15 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
DESCRIPTION="An XML Schema validator and decoder"
-HOMEPAGE="https://github.com/sissaschool/xmlschema https://pypi.org/project/xmlschema/"
+HOMEPAGE="
+ https://github.com/sissaschool/xmlschema/
+ https://pypi.org/project/xmlschema/
+"
SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -19,13 +22,15 @@ IUSE="test"
RESTRICT="!test? ( test )"
RDEPEND="
- >=dev-python/elementpath-2.5.0[${PYTHON_USEDEP}]"
+ >=dev-python/elementpath-2.5.0[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
${RDEPEND}
dev-python/jinja[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- )"
+ )
+"
python_test() {
"${EPYTHON}" tests/test_all.py -v ||