summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-02 09:47:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-02 10:28:03 +0200
commit2db67448b9f23d100ee571b6d7490ee009b30776 (patch)
tree31bf674ff6ca30081c4e4ec966b7134b177a53c6 /dev-python/ypy-websocket
parentdev-python/typing-extensions: Bump to 4.6.3 (diff)
downloadgentoo-2db67448b9f23d100ee571b6d7490ee009b30776.tar.gz
gentoo-2db67448b9f23d100ee571b6d7490ee009b30776.tar.bz2
gentoo-2db67448b9f23d100ee571b6d7490ee009b30776.zip
dev-python/ypy-websocket: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ypy-websocket')
-rw-r--r--dev-python/ypy-websocket/Manifest1
-rw-r--r--dev-python/ypy-websocket/ypy-websocket-0.10.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/ypy-websocket/Manifest b/dev-python/ypy-websocket/Manifest
index 38612af0c795..2811306bb5f1 100644
--- a/dev-python/ypy-websocket/Manifest
+++ b/dev-python/ypy-websocket/Manifest
@@ -1,2 +1,3 @@
+DIST ypy-websocket-0.10.0.gh.tar.gz 14621 BLAKE2B c027ebd10a2a6ac7098d662435eb26b5c3a466d83c22a9db62a795be72df86ce34f0d233f05fb6179f07cf479222db1266c9a5070130da23f87f7adbbb9b471c SHA512 8267a3598c4c0e7b180f1718e9f84e05734f2e75acc971a531bf91cf9eaef4f0f5a4404ba0444aa7664c639ce877fb7409e0a65716dca046fe9423cc8f079b99
DIST ypy-websocket-0.8.4.gh.tar.gz 13416 BLAKE2B 9dd988d6eceb624bae2385180c408971a776f06324407506886c2ef5b8e713277a4c4fb0a2d328a20695d4db8808997c125bfb48faa60c93fe38bb1a1e899766 SHA512 20794b182bbf3958df9f3097ab8c4657acef1ca294c751e0524bc5a36cd7b7a6a2766ae9295cd5f9fc31070813d5b56e0e1e25e22931f63171f88b4757bb1584
DIST ypy-websocket-0.9.0.gh.tar.gz 13677 BLAKE2B 663cf37af7ddddc1bf208da05bc92fc36d866b1a1f86eb2ae1d8362b023db95b68085b5d9eb35b5f34e106f41a819249db6a3d5d102f1c6a5bf04828d2a9cfc7 SHA512 5a193285fafc206de116e087ba10f37ee6e7238968d9c3e88537e054fd8c2238f9bf55c2b2dcb5871b8af9b080caba912a3526e124c33ea3156f19621312cdb4
diff --git a/dev-python/ypy-websocket/ypy-websocket-0.10.0.ebuild b/dev-python/ypy-websocket/ypy-websocket-0.10.0.ebuild
new file mode 100644
index 000000000000..075327cc99bf
--- /dev/null
+++ b/dev-python/ypy-websocket/ypy-websocket-0.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings to y-crdt "
+HOMEPAGE="
+ https://pypi.org/project/ypy-websocket/
+ https://github.com/y-crdt/ypy-websocket/
+"
+SRC_URI="
+ https://github.com/y-crdt/ypy-websocket/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/anyio-4[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.6.2[${PYTHON_USEDEP}]
+ <dev-python/aiosqlite-1[${PYTHON_USEDEP}]
+ >=dev-python/aiosqlite-0.18.0[${PYTHON_USEDEP}]
+ <dev-python/y-py-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/y-py-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvicorn[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Requires internet and nodejs
+ tests/test_ypy_yjs.py
+)
+
+distutils_enable_tests pytest