summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-25 00:55:43 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-25 01:47:58 +0200
commit70f931fdeec972dfa55645853c65760b060e48c6 (patch)
tree4c4cf4029c599a11ff099a12cc2860e4eb4de414 /dev-python/ytmusicapi
parentapp-text/calibre: remove unused patch (diff)
downloadgentoo-70f931fdeec972dfa55645853c65760b060e48c6.tar.gz
gentoo-70f931fdeec972dfa55645853c65760b060e48c6.tar.bz2
gentoo-70f931fdeec972dfa55645853c65760b060e48c6.zip
dev-python/ytmusicapi: bump to 1.8.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python/ytmusicapi')
-rw-r--r--dev-python/ytmusicapi/Manifest1
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-1.8.1.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index 5cc835485be8..323e80748e03 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1 +1,2 @@
DIST ytmusicapi-1.8.0.tar.gz 283301 BLAKE2B aa0d0a8b30b75873865360dfe7b0aec436debf5b2e0f96f2d4008f5234d42802a3a84acd55f83244c03995d605718139f30cda21a798d23c841cc4f9a395d4a5 SHA512 5b7d3fef54eef586b007b6bb6f5c81aaf068302de2493fff8e6ce6bdd9387836615bfa9ecd10ce2516effe1707d11de55ad8a967562e8d6faa527c7e808c377a
+DIST ytmusicapi-1.8.1.tar.gz 283291 BLAKE2B e6894c0bede054e41c485ffa86eb6217d09cc3d619d9ec89777f3575325152acfce98467695dcc95d07e8bb4e3cd8de7c93ee9872373db1958eeb1cabe0ead3c SHA512 37b166e550ead565b752e466ab0ec0fd238474f669b79596a3d16626ed2480ecfe0066715c685f39376ed2ea528993ca2a0330b3c4eac9d4fcd096c8d4c20884
diff --git a/dev-python/ytmusicapi/ytmusicapi-1.8.1.ebuild b/dev-python/ytmusicapi/ytmusicapi-1.8.1.ebuild
new file mode 100644
index 000000000000..b1568c0ab835
--- /dev/null
+++ b/dev-python/ytmusicapi/ytmusicapi-1.8.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unofficial API for YouTube Music"
+HOMEPAGE="https://ytmusicapi.readthedocs.io/
+ https://github.com/sigma67/ytmusicapi/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme