summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-19 04:57:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-19 05:16:43 +0200
commit906b49c7b2348710f035c485f4c9f250d44ce3b5 (patch)
tree101fc6f24fcfe7380966308b9313426be7f71a51 /dev-python/zipp
parentdev-python/pytest-httpx: Bump to 0.26.0 (diff)
downloadgentoo-906b49c7b2348710f035c485f4c9f250d44ce3b5.tar.gz
gentoo-906b49c7b2348710f035c485f4c9f250d44ce3b5.tar.bz2
gentoo-906b49c7b2348710f035c485f4c9f250d44ce3b5.zip
dev-python/zipp: Bump to 3.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest1
-rw-r--r--dev-python/zipp/zipp-3.17.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 826e143abe79..d90746c7ebb7 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1 +1,2 @@
DIST zipp-3.16.2.tar.gz 20002 BLAKE2B abc9b9b2c801f50856e6ad761ff2be81729a475e221716b63c8e017ae87b5f712e43547ba1a42911533f9ad88d02e805768e5bcba397b3f7355d0a8cdcbaab0a SHA512 cb7f19638b2bc2bb1c38241078836c4e484b8f1fae8232073da25967f01e449eb8a6c870d2afde285ea9ae319785a9e4b7cb0e5edc2d0f4690f3ce27c359be93
+DIST zipp-3.17.0.tar.gz 20367 BLAKE2B d1b21b7692e77a019769cd0ab93c850a409bc1eea22e2e6eb0ecaf0c14b5c42a11110b272ee73afb111675f15dfab32aceae6515c05fd4e0c4749352e4be3c90 SHA512 efd100add7e8face19a6163d07b5efbef6f896d1f3ed2dbdd443ed7e523428bd779d1f05dfe806d4d2bbe10c17c21136f2a0b6f0cbe6000dd8a6abb86dede725
diff --git a/dev-python/zipp/zipp-3.17.0.ebuild b/dev-python/zipp/zipp-3.17.0.ebuild
new file mode 100644
index 000000000000..98a174be2fef
--- /dev/null
+++ b/dev-python/zipp/zipp-3.17.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 8 -- sys-apps/portage dep
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="
+ https://github.com/jaraco/zipp/
+ https://pypi.org/project/zipp/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+# big_o is only used in test_complexity, that we ignore
+BDEPEND="
+ test? (
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ dev-python/jaraco-itertools[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # performance tests are flaky by design
+ tests/test_complexity.py
+)
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "zipp"
+ version = "${PV}"
+ description = "Backport of pathlib-compatible object wrapper for zip files"
+ EOF
+}