summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-19 11:30:35 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-19 11:31:39 +0200
commit25dc5ab74c0ce7afa00559e34e613566e4d04958 (patch)
treea59f81f23bcbf8211ad2f597a674c25f63a8cc6c /dev-python
parentnet-misc/getdate: fix build w/ upcoming clang16 (diff)
downloadgentoo-25dc5ab74c0ce7afa00559e34e613566e4d04958.tar.gz
gentoo-25dc5ab74c0ce7afa00559e34e613566e4d04958.tar.bz2
gentoo-25dc5ab74c0ce7afa00559e34e613566e4d04958.zip
dev-python/simpy: update EAPI 7 -> 8, pep517, enable python3_11
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simpy/simpy-4.0.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/simpy/simpy-4.0.1-r1.ebuild b/dev-python/simpy/simpy-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..fac65d7b2095
--- /dev/null
+++ b/dev-python/simpy/simpy-4.0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk"
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+MY_P="${P/simpy/SimPy}"
+
+DESCRIPTION="Object-oriented, process-based discrete-event simulation language"
+HOMEPAGE="https://simpy.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+# Could not import extension sphinx.builders.epub3 (exception: cannot import
+# name 'StandaloneHTMLBuilder' from partially initialized module
+# 'sphinx.builders.html' (most likely due to a circular import)
+# (/usr/lib/python3.10/site-packages/sphinx/builders/html/__init__.py))
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest