summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-01-15 14:55:54 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-15 14:56:11 +0100
commit37928785acd8b6fc0182fb8ad2a39bdb10d94c7b (patch)
treeed12306947c9aa941ccb2d317cea100950c272a0 /dev-python
parentMask dev-libs/boost[mpi] for sparc (diff)
downloadgentoo-37928785acd8b6fc0182fb8ad2a39bdb10d94c7b.tar.gz
gentoo-37928785acd8b6fc0182fb8ad2a39bdb10d94c7b.tar.bz2
gentoo-37928785acd8b6fc0182fb8ad2a39bdb10d94c7b.zip
dev-python/louie: Port to EAPI 6
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/louie/louie-1.1-r1.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/louie/louie-1.1-r1.ebuild b/dev-python/louie/louie-1.1-r1.ebuild
index 13357c81a368..307b3a99c1fb 100644
--- a/dev-python/louie/louie-1.1-r1.ebuild
+++ b/dev-python/louie/louie-1.1-r1.ebuild
@@ -2,17 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
+
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
-MY_PN="Louie"
-MY_P="${MY_PN}-${PV}"
-
DESCRIPTION="Signal dispatching mechanism for Python"
HOMEPAGE="https://pypi.python.org/pypi/Louie"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+SRC_URI="mirror://pypi/L/${PN^}/${P^}.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -23,7 +21,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )"
RDEPEND=""
-S="${WORKDIR}/${MY_P}"
+S="${WORKDIR}/${P^}"
python_prepare_all() {
sed -e "/'nose >= 0.8.3'/d" -i setup.py || die "sed failed"