summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-02 07:05:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-02 07:59:33 +0100
commit4057bb85bbdfb3c12a1ca256f20f66d88849e141 (patch)
tree169550bc5a88b58ebfc15236ea379df43f33c899 /dev-python
parentdev-python/dask: Bump to 2023.12.0 (diff)
downloadgentoo-4057bb85bbdfb3c12a1ca256f20f66d88849e141.tar.gz
gentoo-4057bb85bbdfb3c12a1ca256f20f66d88849e141.tar.bz2
gentoo-4057bb85bbdfb3c12a1ca256f20f66d88849e141.zip
dev-python/Nuitka: Bump to 1.9.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-1.9.3.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 9288afa2f130..e8ae8bf19976 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1,2 +1,3 @@
DIST Nuitka-1.9.1.tar.gz 3909492 BLAKE2B 87d658083ce21d720126c61a8f8ec0df7608d365737475b194c739314d1bab4bcdb647646c1bc64a0371e0fd69c22dab512814d968db3bf02c13741ff34b4f15 SHA512 17a44fa076d4812f56f3fe4aa6b6e4ef38dea328fbc1f6d0c8aa31748b303b8cf057891d4749a43064a12d2c836e03f4ad58830ee56c713cffbae6c8bec50d92
DIST Nuitka-1.9.2.tar.gz 3910444 BLAKE2B a16577c9cb17e1cd99f00dd1974d8154ea2a299c82d3eca06dc60bd526d0ec2d4c0d70d8655d9cfe8178c8fa074bb2a90c3bc28b8869f329e1f0ae04fa63cf4c SHA512 abf4f772512af84d937e2618e3419a53b3ab445505a6aa156810606a23c3dc0252cf9938730987fbc8ed9ccd63afc87d243c909953593ead53d60a0a8a3cd7f8
+DIST Nuitka-1.9.3.tar.gz 3911401 BLAKE2B 83e88d75984074e09be79be5b1ecbe456b304222aad371c92beac109f2a8642ecfbaf39676be9ad26d081defeb63f0022a928ee4d858fa7844e738dafbba95dd SHA512 23ffb85267b219dee3120369f97e74e3e818c58df4928d41ddf14ccab77bac7485c48c2d69c5669038129f2b4b7ccf3ec68b619fc608140609c0003619c36ba9
diff --git a/dev-python/Nuitka/Nuitka-1.9.3.ebuild b/dev-python/Nuitka/Nuitka-1.9.3.ebuild
new file mode 100644
index 000000000000..f511685d5ce1
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.9.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}