summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-17 20:15:09 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-17 20:34:03 +0200
commit461faa68970805f6a1c45e861fdba27ec2248672 (patch)
tree45c5dfa5fc8ac66f50ffe168e6ff120cc9179ac3 /dev-python
parentdev-python/oslo-utils: add github upstream metadata (diff)
downloadgentoo-461faa68970805f6a1c45e861fdba27ec2248672.tar.gz
gentoo-461faa68970805f6a1c45e861fdba27ec2248672.tar.bz2
gentoo-461faa68970805f6a1c45e861fdba27ec2248672.zip
dev-python/zope-interface: add 5.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zope-interface/Manifest1
-rw-r--r--dev-python/zope-interface/zope-interface-5.5.2.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/zope-interface/Manifest b/dev-python/zope-interface/Manifest
index a78a96d3386a..f85293d10ba4 100644
--- a/dev-python/zope-interface/Manifest
+++ b/dev-python/zope-interface/Manifest
@@ -1,2 +1,3 @@
DIST zope.interface-5.5.0.tar.gz 253292 BLAKE2B 2c3e48aeff7124a50b834792774596bd3ed793146be7335a0b3abbaf0e1861d84668421b9098cf4f8986d17f8f148a7b30b929ea73b5d344e5d63d44270b2a99 SHA512 ab74a55a90c17b1aed55f1d6e24365321ebbca5943557be7731af99d7436f18f4d0a4c53c0c26c29c0379ce72ef0c2babccaa9cad5aec843bc533ff19fdbe6d9
DIST zope.interface-5.5.1.tar.gz 300064 BLAKE2B a40de949efc269e3b942eaa6bd5006afc253487149ef22fd1d070eb15535ad755a34cd3e3ab053652cbd1117aef92fe79e8de683491c8e8eaa41e4da8b9b12bd SHA512 e5d73a78a8d9960cf8f24a7603175b0ebe0f2a3695536cdcecb5f78a6ee118aaa8fdf26c70d08a9d17f70e9b89024c260c732e2f9c9153ab960f3175fc10b9df
+DIST zope.interface-5.5.2.tar.gz 300533 BLAKE2B 04b348492d5af729eebc6b1abc6dc7bd4a28931c5d65d03261bc4a77a39e97c4cbcf319ea0b5a960ddab7bd1056481e741d2b69cf6c21bea4bf3885b757aa1bd SHA512 ecc20df9b84c91f7a03ce7be087abcd6288f77b2e04f6974ece5b86a222944baf0dc0a2aa49063c74dc7c4d47c474fd01f512c7686164806d48f360667581205
diff --git a/dev-python/zope-interface/zope-interface-5.5.2.ebuild b/dev-python/zope-interface/zope-interface-5.5.2.ebuild
new file mode 100644
index 000000000000..6a87c71f939f
--- /dev/null
+++ b/dev-python/zope-interface/zope-interface-5.5.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Interfaces for Python"
+HOMEPAGE="
+ https://github.com/zopefoundation/zope.interface/
+ https://pypi.org/project/zope.interface/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ !dev-python/namespace-zope
+"
+BDEPEND="
+ test? (
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/5.1.0-drop-coverage.patch
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -e "/'setuptools'/d" -i setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}