summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-22 07:06:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-22 07:06:08 +0200
commit4b5e47165c4b13c0198b30ee4e595d06b0406c2d (patch)
tree0dcefae80cccf0d1c2fa02c1d724d92379278588 /dev-python
parentdev-python/jaraco-path: Bump to 3.7.1 (diff)
downloadgentoo-4b5e47165c4b13c0198b30ee4e595d06b0406c2d.tar.gz
gentoo-4b5e47165c4b13c0198b30ee4e595d06b0406c2d.tar.bz2
gentoo-4b5e47165c4b13c0198b30ee4e595d06b0406c2d.zip
dev-python/importlib-resources: Bump to 6.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/importlib-resources/Manifest1
-rw-r--r--dev-python/importlib-resources/importlib-resources-6.4.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/importlib-resources/Manifest b/dev-python/importlib-resources/Manifest
index 6d473e835ce5..f56449d4a77c 100644
--- a/dev-python/importlib-resources/Manifest
+++ b/dev-python/importlib-resources/Manifest
@@ -1,3 +1,4 @@
DIST importlib_resources-6.4.0.tar.gz 42040 BLAKE2B 55b52a42051c6900af7b5b70783476a48398ae02539871a3f508df08fd5b4ec03bbe40980de8cd49a60cc022905a4ffdfd95b55d70e0cfb5d64497b02cc9b88f SHA512 c600e7ba96431f15a929e5acda89a262ceef33a3f44ae361fad4201dde8033dd8f0f2bcb856619fd5e21209a5d17cf9ae3610e65c3e6ecd0e36545437d0064b9
DIST importlib_resources-6.4.2.tar.gz 41629 BLAKE2B 21bfb0af9421f49acce3209ec93016b69626a179d65f48066abea8792292506b739460675cc9c0ce552d11db261af409d5aa2bab2b7b16c3daab133873d3a353 SHA512 e3bb0e1ccf35fe36f805a97ff71cd82d9e55547baf1c6083bec07c2528cb1f11497926f76917cfba3924c04d6fd5753ccfbb912fdf08174c5b63f5f1a198acf5
DIST importlib_resources-6.4.3.tar.gz 42026 BLAKE2B 8a88825467bf558b4232ce4f1600ceda56b67283d93182d0144b5cabe6227bdf79e24a8fb6cef47d7cc59cc9cc293e70c7a2cd7ab1512a523f04cf167ac27cdb SHA512 23b6e8d37d2317cfe9d465f8083b6fa8826c34ec114844993556657b943ecca3b3d6e5f4ca958787d980ebd451e174b8e134f35445bdef085ca29b71c76e248e
+DIST importlib_resources-6.4.4.tar.gz 42721 BLAKE2B 4e38bba910e2de9e53297151f6fd9a839534b7aca1a98c4c053c420eba4b137b7ca60a32dce84f3ed5c558e3bfbf3f90fea48f3e6e7e8921c2961756ef96eb04 SHA512 ffdd2cbe56ae308392e9fcadbd5822b68afd5737a78b04416e84a1ca294ce33f4f0df5ff5ee4e403f43064c9bf33df3d2742809d651295b536d0036f7359580c
diff --git a/dev-python/importlib-resources/importlib-resources-6.4.4.ebuild b/dev-python/importlib-resources/importlib-resources-6.4.4.ebuild
new file mode 100644
index 000000000000..0621ce95769b
--- /dev/null
+++ b/dev-python/importlib-resources/importlib-resources-6.4.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+# backport from py3.12
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Read resources from Python packages"
+HOMEPAGE="
+ https://github.com/python/importlib_resources/
+ https://pypi.org/project/importlib-resources/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/jaraco-test-5.4[${PYTHON_USEDEP}]
+ >=dev-python/zipp-3.17[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest