summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-24 10:00:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-24 10:00:11 +0100
commit4d661a82dc590c1b4834f1ed3e5970685dd3eed0 (patch)
tree4096031ca6c17b234ff0fac0500f60382caa4080 /dev-python
parentnet-im/zoom: Add mesa[gbm] USE dependency for libgbm (diff)
downloadgentoo-4d661a82dc590c1b4834f1ed3e5970685dd3eed0.tar.gz
gentoo-4d661a82dc590c1b4834f1ed3e5970685dd3eed0.tar.bz2
gentoo-4d661a82dc590c1b4834f1ed3e5970685dd3eed0.zip
dev-python/botocore: Bump to 1.24.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.24.25.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5429d906f551..c50016584ed2 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -7,4 +7,5 @@ DIST botocore-1.24.21.tar.gz 8837199 BLAKE2B 34b321900ff52b5d8fbde87160745243fed
DIST botocore-1.24.22.tar.gz 8839717 BLAKE2B 7b3843900da913561ab2a99f7371139cd8fd89a2eb52a90b33f8fb4c0449ff23a00f56347a2916b271346acf2c0721af0a9695bff3663888aa87c790705ce4c3 SHA512 070222b5eca46fa5463620af63816bc8813c717a56b4c41294556130390959ac14570a1256542f145a5b36727ced9657b386fcd5f538d64912c8a9f049673bd6
DIST botocore-1.24.23.tar.gz 8842041 BLAKE2B 0e1bf7001fc09d165fa652406815bc5fc7d6055967d4975c9d28b4abc9841fb761af65fe6a38ed9e0d81e7d846e74e3717103debad4d69c62bd41125371b4d4f SHA512 5bd77d0f0db0da5037711e4a61362bbd48512b8f785ce104690b1275608a59594d9f64b878777081f21b0f6a6b22b19f12cb7a068c4d1e0a1b044d5146acf888
DIST botocore-1.24.24.tar.gz 8842777 BLAKE2B 36ef7f82a15b3e9a3babcc6e68efd6e57f3a54d69bc4e281ecb2693053663fdb6ca7a2844b65447ca0ea4d61af9354024691a187d45f20da552b36783316781c SHA512 e9e0c5723eba2f29e5c06ce6530176db2a13bc2edd9d4f08d7c72a4b865bedd3045875417e07e9252fd9cff8d1c1c45bf0270534494482b1588bc13da253376a
+DIST botocore-1.24.25.tar.gz 8852839 BLAKE2B feb0f5de1d34b9f5a1b20f76480f432059c74293c70d310234beb8515741883d639dc54d7843d47e03aa107846d1a83af29fb98e6cc519aea289841a17464f56 SHA512 d2bb402bff2af857d433b379d81b727120543de6a5cf3d13f0c5dd60cef219fd5ea6362156c5284bb06860ec2ca0f1823fce4dccda03e4213eb737e45470ca0d
DIST botocore-1.24.8.tar.gz 8798121 BLAKE2B 4ca37ed7be0af62901bf154f75739cc7e07505a809e551884c72d5b5eed334fff1111fc6db016df522564a1f3d9b6f258e8eca96161a734711340bf880b553b5 SHA512 6ac2139694ab199313a0fb9a2f783b12de7f3915d10cba739f4758356a3b84a917c3c394954b6d82d7a62de907c6fe57a3559e2b9a625bb0479e7bacd31d21cc
diff --git a/dev-python/botocore/botocore-1.24.25.ebuild b/dev-python/botocore/botocore-1.24.25.ebuild
new file mode 100644
index 000000000000..3bf7c7cfb689
--- /dev/null
+++ b/dev-python/botocore/botocore-1.24.25.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}