summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-14 03:37:32 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 04:23:33 +0100
commit53ee2e04ae3e72fe9ceb21859289507b3029cb8f (patch)
tree94b4dc3f17196b5a44892fd6faa0f6e71a6d8dd2 /dev-python
parentdev-build/meson: Stabilize 1.3.0-r2 hppa, #921373 (diff)
downloadgentoo-53ee2e04ae3e72fe9ceb21859289507b3029cb8f.tar.gz
gentoo-53ee2e04ae3e72fe9ceb21859289507b3029cb8f.tar.bz2
gentoo-53ee2e04ae3e72fe9ceb21859289507b3029cb8f.zip
dev-python/hypothesis: Bump to 6.93.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.93.0.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6659b515747c..1720e2354bde 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-6.92.6.gh.tar.gz 9410707 BLAKE2B 337369c5044682b3404ba0492cdab83
DIST hypothesis-6.92.7.gh.tar.gz 9412316 BLAKE2B eae3a5d46dde5d69ab5fea429178eebeed06bec4ff25744324a3ed75e9433ac9652eb467a3a0a32fbbbe9924913f25ac87b375d1cf27c82fa5b024bdcbcdb791 SHA512 5fd04e49d76ec42dea4575666ed19ee249ef8cdcdca81d8c652b79fa879d51cfecd1851245c9b950627227d42c7520f7396816d2a8cc66991e1abc955a2c6cbd
DIST hypothesis-6.92.8.gh.tar.gz 9412899 BLAKE2B 48bd1218f20260b983df4c75def1ad30a48d368975e5cf64bcc0eeb5148bd8cd2afe9b9b912304f13be791ca35f99bade225bcd7e600687a8249060b8b1767bf SHA512 ce5b97360dc45f4cbc26a7c68b1b7200e9906821200207479be80ab0c4bab5f5c363d1e914bc163eda096e575560146cdeb5f129b0ffd1545455df427c00cac2
DIST hypothesis-6.92.9.gh.tar.gz 9413220 BLAKE2B 066b291fe6df2d14a15c77be63196c26d27764ba69c6de4a417a6117a770b3305d8ff981643e62776d8254a7e2248741d4c7da6489adcb1a0fb641776f3520ef SHA512 1e9e81963aaa23d4b6d2290cca4644498a10aadd6a2417511ac57466ee87ebc89cc3b34eb7367af131916b04304aa52c3f736a5557a7e757fda5d40af478332a
+DIST hypothesis-6.93.0.gh.tar.gz 9413948 BLAKE2B 1cb75543757163b5ceffd4050f5eea9d1953f607f935af0ac290c56ccd48e62cfbfe6f124a4162c395c30f985dc7426bcc70d348c27dc515b89ca1a1b8fa2e95 SHA512 20f7727ef77cd961ed4368c4441dd1aa49495d19a4f486e84234360f0280f1f4b848915a19f0445b31c3f66b9f25e65a000dc147852bc2fa1ef42e35be31a0d7
diff --git a/dev-python/hypothesis/hypothesis-6.93.0.ebuild b/dev-python/hypothesis/hypothesis-6.93.0.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.93.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}