summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-21 09:13:23 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-21 09:33:46 +0200
commit7e3bd370988e4f26f4f51d5cd6aad79f42f111c2 (patch)
tree0dc533a457f47c12d540a2de35eff35e1c631392 /dev-python
parentsys-devel/clang: Add 9.0 branch live ebuild (diff)
downloadgentoo-7e3bd370988e4f26f4f51d5cd6aad79f42f111c2.tar.gz
gentoo-7e3bd370988e4f26f4f51d5cd6aad79f42f111c2.tar.bz2
gentoo-7e3bd370988e4f26f4f51d5cd6aad79f42f111c2.zip
dev-python/clang-python: Add 9.0 branch live ebuild
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/clang-python/clang-python-9.0.9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/clang-python/clang-python-9.0.9999.ebuild b/dev-python/clang-python/clang-python-9.0.9999.ebuild
new file mode 100644
index 000000000000..6bf0e1c8573f
--- /dev/null
+++ b/dev-python/clang-python/clang-python-9.0.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit git-r3 python-r1
+
+DESCRIPTION="Python bindings for sys-devel/clang"
+HOMEPAGE="https://llvm.org/"
+SRC_URI=""
+EGIT_REPO_URI="https://git.llvm.org/git/clang.git
+ https://github.com/llvm-mirror/clang.git"
+EGIT_BRANCH="release_90"
+
+LICENSE="UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# The module is opening libclang.so directly, and doing some blasphemy
+# on top of it.
+RDEPEND="
+ >=sys-devel/clang-${PV}:*
+ !sys-devel/llvm:0[clang(-),python(-)]
+ !sys-devel/clang:0[python(-)]
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}/bindings/python
+
+src_unpack() {
+ git-r3_fetch
+ git-r3_checkout '' '' '' bindings/python
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}
+
+src_test() {
+ python_foreach_impl python_test
+}
+
+src_install() {
+ python_foreach_impl python_domodule clang
+}