summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-23 07:35:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-23 08:16:22 +0200
commita7a2fddcc0b6ef48f56773f1d815124af9b5b859 (patch)
tree3dc7700c488a1bf500684169b60c70fa1f51f822 /dev-python
parentdev-python/rich: Bump to 13.9.3 (diff)
downloadgentoo-a7a2fddcc0b6ef48f56773f1d815124af9b5b859.tar.gz
gentoo-a7a2fddcc0b6ef48f56773f1d815124af9b5b859.tar.bz2
gentoo-a7a2fddcc0b6ef48f56773f1d815124af9b5b859.zip
dev-python/pyftpdlib: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyftpdlib/Manifest1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index a5a120fa064a..c34a3d64f77a 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1 +1,2 @@
DIST pyftpdlib-2.0.0.tar.gz 196108 BLAKE2B bec261eac70a93092055413fca67dd4a480e492481f027b32508dcee8b479dbc0ec84c56d972dca63f2fbf4e3240e02b1c2877105cf77130bf75b64c9785993e SHA512 c154127771b949854c05f87a7b77f1cf144e2756cb0709c44cd0921c2ac415e7c6336c6dca1982b762087a42fc1408e26fbb2ebecbf9255d6f2d6019af14ccfe
+DIST pyftpdlib-2.0.1.tar.gz 202285 BLAKE2B 16e25d45a7d832e0a35e810d3017091e4a00b25b85cefac16182ce36e213ee09119d0705f84e3b6c92b7c7becd80c8e91245f5591dd7e88daa4944fdcc472940 SHA512 b913d2deaa9d16239eca1e00fe9b01c33222173242b1b6d5513de563cdd4a5c3bf346cbd1d6044c74b16a7691a4b619a01aff373e2f94e08f232f13e3383d99b
diff --git a/dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild b/dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild
new file mode 100644
index 000000000000..f28406bf5316
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-2.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="
+ https://github.com/giampaolo/pyftpdlib/
+ https://pypi.org/project/pyftpdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples ssl"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pyasynchat[${PYTHON_USEDEP}]
+ dev-python/pyasyncore[${PYTHON_USEDEP}]
+ ' 3.12 3.13)
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ rm -rf pyftpdlib || die
+ # Some of these tests tend to fail
+ local EPYTEST_DESELECT=(
+ # fail because they process sys.argv and expect program args
+ # rather than pytest args, sigh
+ test/test_misc.py
+ # TODO
+ test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ )
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyftpdlib
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}