summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-29 16:23:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-29 18:29:45 +0200
commitb8f391157673a8a615c96f25d2773bc8ce320a17 (patch)
treec167afd8aa4503b400f090c2588abe23cbf5c085 /dev-python
parentmedia-libs/openexr: add [zlib(+)] to libdeflate (diff)
downloadgentoo-b8f391157673a8a615c96f25d2773bc8ce320a17.tar.gz
gentoo-b8f391157673a8a615c96f25d2773bc8ce320a17.tar.bz2
gentoo-b8f391157673a8a615c96f25d2773bc8ce320a17.zip
dev-python/orderly-set: New package, v5.2.2
New NIH dependency for dev-python/deepdiff. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/orderly-set/Manifest1
-rw-r--r--dev-python/orderly-set/metadata.xml12
-rw-r--r--dev-python/orderly-set/orderly-set-5.2.2.ebuild35
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/orderly-set/Manifest b/dev-python/orderly-set/Manifest
new file mode 100644
index 000000000000..358b3bb944d6
--- /dev/null
+++ b/dev-python/orderly-set/Manifest
@@ -0,0 +1 @@
+DIST orderly-set-5.2.2.gh.tar.gz 21460 BLAKE2B 5660d7550d5c79351fcc66e611ba776d6340d0fc1f3a5344f308cbc00a7b2c47045a1cfe8c6ac76c7976a65b17953362e91d60d87a7fbb02f36a5d67f074dfe9 SHA512 d480677c04f32e69cc9361dff383765fe2c9df971ad77cdcbab3b650a0bad27b9bd99144cd406d5185440d674bc838acb1c2ba3a4b115fcff2eba34c19589637
diff --git a/dev-python/orderly-set/metadata.xml b/dev-python/orderly-set/metadata.xml
new file mode 100644
index 000000000000..7d4c31d1ff3b
--- /dev/null
+++ b/dev-python/orderly-set/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">seperman/orderly-set</remote-id>
+ <remote-id type="pypi">orderly-set</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/orderly-set/orderly-set-5.2.2.ebuild b/dev-python/orderly-set/orderly-set-5.2.2.ebuild
new file mode 100644
index 000000000000..8b0953ce7def
--- /dev/null
+++ b/dev-python/orderly-set/orderly-set-5.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A package containing multiple implementations of Ordered Set"
+HOMEPAGE="
+ https://github.com/seperman/orderly-set/
+ https://pypi.org/project/orderly-set/
+"
+# incomplete test directory
+# https://github.com/seperman/orderly-set/pull/3
+SRC_URI="
+ https://github.com/seperman/orderly-set/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditional mypy dep for a test that is not even run
+ # https://github.com/seperman/orderly-set/pull/5
+ sed -i -e '/mypy\.api/d' tests/*.py || die
+}