summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-16 17:54:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-16 18:30:06 +0100
commitc019806491d3edf27ebd65925f8702fc6cb0d1a3 (patch)
treec29d39bf0dec6b0a963cae710c9d26eb65ee4d8f /dev-python
parentdev-python/nbconvert: Bump to 7.14.2 (diff)
downloadgentoo-c019806491d3edf27ebd65925f8702fc6cb0d1a3.tar.gz
gentoo-c019806491d3edf27ebd65925f8702fc6cb0d1a3.tar.bz2
gentoo-c019806491d3edf27ebd65925f8702fc6cb0d1a3.zip
dev-python/jsonschema: Bump to 4.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonschema/Manifest1
-rw-r--r--dev-python/jsonschema/jsonschema-4.21.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/jsonschema/Manifest b/dev-python/jsonschema/Manifest
index 7acecefd78df..4616395575d6 100644
--- a/dev-python/jsonschema/Manifest
+++ b/dev-python/jsonschema/Manifest
@@ -1,2 +1,3 @@
DIST jsonschema-4.17.3.tar.gz 297785 BLAKE2B a0383bf5612ae50e94c95dbc1774d796b62c74a7aae3056a40edb7e042ad07fd7885e61d86220120a906a4017afe30d8ee8edbbf0cf01a6dec1f212984ff1c1e SHA512 626fc913c37d2e49e4b47c9e058aab4a96c1dc50c35d8def0b2ea0ca464dc25e3318d4fde4927c11ca38068743cd81779d5189464b821407ac1de1788bad30e2
DIST jsonschema-4.20.0.tar.gz 320243 BLAKE2B 7782665aa97d080a3ade9f0ed600d84602135ba80641c75d027f31f118432d206d5c61243e90a59aa134bce2fcf6bed6aed685bca9ad243178c78d3002d43b66 SHA512 916ce6e5a1cce19e52d34394797d59c4821a3e7abad0248d929a8d5975e8e5a2c0a270b2839d6e1800037a53d0ed8fd38ca44264a88653b5aaba1705d459cb47
+DIST jsonschema-4.21.0.tar.gz 321324 BLAKE2B 0c2bcf26fd9cb2c5ce86bb556a1312b861984373bde30e7dae42dce7711967e0e0f51b648cb2683786240c743f276ce81a4ef70fb66ab878e783602c77d903b2 SHA512 7467a1c70e587d32c2d196050b60f01a765a27ac0c97f4481c2c654381863911999e7b8f7592ec6ce24a92fb81f4de4ce5197652977a82ace5b75928a6c2334c
diff --git a/dev-python/jsonschema/jsonschema-4.21.0.ebuild b/dev-python/jsonschema/jsonschema-4.21.0.ebuild
new file mode 100644
index 000000000000..a7d67335f628
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.21.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-specifications-2023.03.6[${PYTHON_USEDEP}]
+ >=dev-python/referencing-0.28.4[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ test? (
+ !!dev-python/shiboken6
+ )
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri-template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # fragile warning tests
+ jsonschema/tests/test_deprecations.py
+ # wtf?
+ jsonschema/tests/test_jsonschema_test_suite.py::test_suite_bug
+)