summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-01 06:28:05 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-01 06:38:18 +0100
commitcae63c37c5e2c1b9dc082f57cd7641d7995d5ada (patch)
treeb6908a780a640601c1022c7d928c938fcfe72bf7 /dev-python
parentdev-python/google-auth: Bump to 2.24.0 (diff)
downloadgentoo-cae63c37c5e2c1b9dc082f57cd7641d7995d5ada.tar.gz
gentoo-cae63c37c5e2c1b9dc082f57cd7641d7995d5ada.tar.bz2
gentoo-cae63c37c5e2c1b9dc082f57cd7641d7995d5ada.zip
dev-python/jsonschema-specifications: Bump to 2023.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonschema-specifications/Manifest1
-rw-r--r--dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/jsonschema-specifications/Manifest b/dev-python/jsonschema-specifications/Manifest
index 0b531a0b2694..a50891116099 100644
--- a/dev-python/jsonschema-specifications/Manifest
+++ b/dev-python/jsonschema-specifications/Manifest
@@ -1 +1,2 @@
DIST jsonschema_specifications-2023.11.1.tar.gz 12935 BLAKE2B 317c6c937f0939ec59e25f2d84a6eea30ae4d8f14c4787e282dc9d6d4b74d84ab4985fde8f78f0cffa0fc61efe44493afe9d79182f4c02b0d6caff18f15dfd08 SHA512 a917226f5341c2a8913fa87a9640e1a5fdb34c857a8be1a0618db15cd09de0d45e82b294f759177de5fbe002f1ad9a04196c1c0976cc99ec685764b30e648b8d
+DIST jsonschema_specifications-2023.11.2.tar.gz 13033 BLAKE2B a9e64f1956a80f040eb300b772e10c7f75ed36502b69899bcadaef79086bc209d63b139bfe94cc3f30ee250bd50b9e0021e3c7616cecd08b322160cadba69046 SHA512 de990c8e6976a2a5915f9b5882f4b9da1cbe8c63a9de70aff74efeb2c659f041815186c6cb38ca9df14fefc211cae2b3c7c8af838fc4b9b853b07f7a5362f181
diff --git a/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild
new file mode 100644
index 000000000000..9c3a40e4cef7
--- /dev/null
+++ b/dev-python/jsonschema-specifications/jsonschema-specifications-2023.11.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="The JSON Schema meta-schemas and vocabularies, exposed as a Registry"
+HOMEPAGE="
+ https://github.com/python-jsonschema/jsonschema-specifications/
+ https://pypi.org/project/jsonschema-specifications/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/referencing-0.31.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest