summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-17 03:46:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-17 04:19:11 +0200
commitce137848f03e10e0df7aeef634b6dded2c4581c4 (patch)
treedcbd48c7efbe127b99a31cbf4d0362a1b7902c0d /dev-python
parentsci-libs/umfpack: update EAPI 7 -> 8 (diff)
downloadgentoo-ce137848f03e10e0df7aeef634b6dded2c4581c4.tar.gz
gentoo-ce137848f03e10e0df7aeef634b6dded2c4581c4.tar.bz2
gentoo-ce137848f03e10e0df7aeef634b6dded2c4581c4.zip
dev-python/argcomplete: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/argcomplete/Manifest1
-rw-r--r--dev-python/argcomplete/argcomplete-3.4.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 24a4bccc2f52..15c169b0b93e 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1 +1,2 @@
DIST argcomplete-3.3.0.tar.gz 81832 BLAKE2B 63778dc48f90bb06dbf59c8d4d94ca905c9b188ec5b64e3a8cf7604d66cf075b31350f241da00e460d97b1920c620d4fbf8df772485987897a698cec060b6ec9 SHA512 30776b7e2dc3ee1f7dfcd665d2ae6e403b09644829c1cd7a30ce80e39c6bd7331cc0b7bd7d6cec58a409ef6ec209ca6b1cca0888e83a7a9a228658fa72f6e578
+DIST argcomplete-3.4.0.tar.gz 82275 BLAKE2B 18b81aa5ee0c148a3b935f157f4c39b0ade79b36c8e3aa94aa7af8a424a08793a4cf661cb2431c201d5eead02e12c35b78d351310ff4e4e750bf7d7dc702ca89 SHA512 bd619a34edf1f1d05bdfab7fa830d1fc5375bc292dc95b95ddc4d3bfaced5728067e6ad0a901f672b7e0d5a550c10b00e0851f83cf9b358301c037da256a4a56
diff --git a/dev-python/argcomplete/argcomplete-3.4.0.ebuild b/dev-python/argcomplete/argcomplete-3.4.0.ebuild
new file mode 100644
index 000000000000..645def2f41b7
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.4.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+PATCHES=(
+ # increase test timeouts -- this is particularly necessary
+ # for entry point tests because they read metadata of all installed
+ # packages which can take real long on systems with lots of packages
+ "${FILESDIR}/argcomplete-3.1.6-timeout.patch"
+)
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}