summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-30 04:36:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-30 04:45:47 +0200
commitd11ce113549e4f8478083a4ac4b5eef8847b6ef3 (patch)
treef620d87aacaddf8f1462c00ea2eb186ed58ed173 /dev-python
parentdev-python/python-openstackclient: Bump to 6.6.1 (diff)
downloadgentoo-d11ce113549e4f8478083a4ac4b5eef8847b6ef3.tar.gz
gentoo-d11ce113549e4f8478083a4ac4b5eef8847b6ef3.tar.bz2
gentoo-d11ce113549e4f8478083a4ac4b5eef8847b6ef3.zip
dev-python/tenacity: Bump to 9.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-9.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 669d9b68a546..8713f5dbcc8a 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-8.5.0.tar.gz 47309 BLAKE2B 6d3e1dbcac5facf9c838e13fa3cb0ff03c22cb490cf9ed17aea44e4486f7f256918415779adf3854e4ebb2b2496686265acf2f5e42621b01aa3b6d43910cd828 SHA512 f5568233321bbc6c6cfca0f362f627ff6eecf6094c55644ae46448b5f1d6466928a35a1435c97004b640ac95444e4e8c0bb2b21520e2bba5c619eeff36955e72
+DIST tenacity-9.0.0.tar.gz 47421 BLAKE2B f263af6be0c2d3f26969884d0f211111c68d28dc0cdeddc4ff03791cb5344e60a481a80321d6946bbc9982fac61d0b6084e299766e620893cc30fdc8dae39a8d SHA512 c6236e7630d46048c7c8fb60213591b3489576b8a4413f0bc2d692751f456882c177bdbc425d5921d7679a019dd39371dfa5cd1210e68a3faefd5beb799961ea
diff --git a/dev-python/tenacity/tenacity-9.0.0.ebuild b/dev-python/tenacity/tenacity-9.0.0.ebuild
new file mode 100644
index 000000000000..f8e2d233c9f3
--- /dev/null
+++ b/dev-python/tenacity/tenacity-9.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/tornado-6.4-r1[${PYTHON_USEDEP}]
+ dev-python/typeguard[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile to timing
+ tests/test_asyncio.py::TestContextManager::test_sleeps
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}