summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-14 06:12:42 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-14 06:12:42 +0100
commitdbe1542d27db83967e393d77b998d4b4348b8141 (patch)
treefe6b75773046885b3f17fafebff9803eadccee8e /dev-python
parentdev-python/pyproject-fmt: Bump to 0.9.1 (diff)
downloadgentoo-dbe1542d27db83967e393d77b998d4b4348b8141.tar.gz
gentoo-dbe1542d27db83967e393d77b998d4b4348b8141.tar.bz2
gentoo-dbe1542d27db83967e393d77b998d4b4348b8141.zip
dev-python/podman-py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/podman-py/Manifest1
-rw-r--r--dev-python/podman-py/files/podman-py-4.3.0-tomli.patch89
-rw-r--r--dev-python/podman-py/podman-py-4.3.0-r1.ebuild54
3 files changed, 0 insertions, 144 deletions
diff --git a/dev-python/podman-py/Manifest b/dev-python/podman-py/Manifest
index 5dc66a78d649..b4dc902c91e0 100644
--- a/dev-python/podman-py/Manifest
+++ b/dev-python/podman-py/Manifest
@@ -1,2 +1 @@
-DIST podman-py-4.3.0.gh.tar.gz 177403 BLAKE2B 549d3aba023423e5ae45fb04e0ec67bdb8ef6cdbe3e4fe6dec2f5e4d1f1df08828aed00aa83b7ad26f6c88ba225211a108ff67ba28e0003827c00ce3c32428ea SHA512 4e7c1f23d7baf425079689635c2b468871eff7f898f150b9244faf3d199a1cf2544aee1f633e431cd40701fbaaa41861d894e72486a38c6a198fd2c33691b826
DIST podman-py-4.4.0.gh.tar.gz 177587 BLAKE2B 92d2a45a20304be648247fe8c95ab7ed84795e419d79fc731a6be4f228851b10324546b9cd14f9235a3972fd9258d50b2512216121c0fef59c0eb66d7c12c91c SHA512 47b4157fd9e6d54171f6f970012e828f877c66c4fabe4f30ad93974945b9e35fa7084c2908efca42c8b71a8d9f25e7a29a624152ce7bea1eebafcaa3700cb967
diff --git a/dev-python/podman-py/files/podman-py-4.3.0-tomli.patch b/dev-python/podman-py/files/podman-py-4.3.0-tomli.patch
deleted file mode 100644
index 0be9ab796217..000000000000
--- a/dev-python/podman-py/files/podman-py-4.3.0-tomli.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From c5a356fb4ea8a6fb66a6d20bdc2c9cffe615028b Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Fri, 14 Oct 2022 13:54:31 +0200
-Subject: [PATCH] Use modern tomllib/tomli modules for reading TOML files
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Replace the unmaintained `toml`/`pytoml` dependencies with the modern
-alternatives: the built-in `tomllib` module in Python 3.11, and `tomli`
-in older Python versions. Preserving backwards compatibility does not
-seem necessary, as podman-py no longer supports Python versions older
-than 3.6.
-
-Signed-off-by: Michał Górny <mgorny@gentoo.org>
----
- podman/domain/config.py | 16 ++++++++++------
- pyproject.toml | 2 +-
- python-podman.spec.rpkg | 8 ++++----
- requirements.txt | 2 +-
- setup.cfg | 2 +-
- 5 files changed, 17 insertions(+), 13 deletions(-)
-
-diff --git a/podman/domain/config.py b/podman/domain/config.py
-index 555ed9d..6ea8eb6 100644
---- a/podman/domain/config.py
-+++ b/podman/domain/config.py
-@@ -1,17 +1,21 @@
- """Read containers.conf file."""
-+import sys
- import urllib
- from pathlib import Path
- from typing import Dict, Optional
-
- import xdg.BaseDirectory
-
--try:
-- import toml
--except ImportError:
-- import pytoml as toml
--
- from podman.api import cached_property
-
-+if sys.version_info >= (3, 11):
-+ from tomllib import loads as toml_loads
-+else:
-+ try:
-+ from tomli import loads as toml_loads
-+ except ImportError:
-+ from toml import loads as toml_loads
-+
-
- class ServiceConnection:
- """ServiceConnection defines a connection to the Podman service."""
-@@ -64,7 +68,7 @@ def __init__(self, path: Optional[str] = None):
- if self.path.exists():
- with self.path.open(encoding='utf-8') as file:
- buffer = file.read()
-- self.attrs = toml.loads(buffer)
-+ self.attrs = toml_loads(buffer)
-
- def __hash__(self) -> int:
- return hash(tuple(self.path.name))
-diff --git a/pyproject.toml b/pyproject.toml
-index f3cdfb9..3b29ecb 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -25,7 +25,7 @@ requires = [
- "requests>=2.24",
- "setuptools>=46.4",
- "sphinx",
-- "toml>=0.10.2",
-+ "tomli>=1.2.3; python_version<'3.11'",
- "urllib3>=1.24.2",
- "wheel",
- ]
-diff --git a/setup.cfg b/setup.cfg
-index f8d1b6f..2066951 100644
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -36,7 +36,7 @@ test_suite =
- install_requires =
- pyxdg>=0.26
- requests>=2.24
-- toml>=0.10.2
-+ tomli>=1.2.3; python_version<'3.11'
- urllib3>=1.24.2
-
- # typing_extensions are included for RHEL 8.5
diff --git a/dev-python/podman-py/podman-py-4.3.0-r1.ebuild b/dev-python/podman-py/podman-py-4.3.0-r1.ebuild
deleted file mode 100644
index e223cbf3882a..000000000000
--- a/dev-python/podman-py/podman-py-4.3.0-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A library to interact with a Podman server"
-HOMEPAGE="
- https://github.com/containers/podman-py/
- https://pypi.org/project/podman/
-"
-SRC_URI="
- https://github.com/containers/podman-py/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- >=dev-python/pyxdg-0.26[${PYTHON_USEDEP}]
- >=dev-python/requests-2.24[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.24.2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/tomli-1.2.3[${PYTHON_USEDEP}]
- ' 3.{8..10})
-"
-BDEPEND="
- test? (
- dev-python/requests-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-tomli.patch
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
- )
-
- # integration tests require a workable podman server,
- # and it doesn't seem to work in ebuild env
- epytest podman/tests/unit
-}