summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-27 13:44:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-27 16:57:16 +0200
commite376a87c69a55b465091a4acf70aea4a6e9788a0 (patch)
tree1f5924ab491a47bc3eeb6bf2cd9f623a5f38c461 /dev-python
parentdev-ml/seq: not needed for ocaml >= 4.07 (diff)
downloadgentoo-e376a87c69a55b465091a4acf70aea4a6e9788a0.tar.gz
gentoo-e376a87c69a55b465091a4acf70aea4a6e9788a0.tar.bz2
gentoo-e376a87c69a55b465091a4acf70aea4a6e9788a0.zip
dev-python/twisted: Fix dependencies
Closes: https://bugs.gentoo.org/878333 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/twisted/twisted-22.8.0-r1.ebuild (renamed from dev-python/twisted/twisted-22.8.0.ebuild)38
1 files changed, 20 insertions, 18 deletions
diff --git a/dev-python/twisted/twisted-22.8.0.ebuild b/dev-python/twisted/twisted-22.8.0-r1.ebuild
index cc8b055c6b38..eb99611e14b6 100644
--- a/dev-python/twisted/twisted-22.8.0.ebuild
+++ b/dev-python/twisted/twisted-22.8.0-r1.ebuild
@@ -25,30 +25,31 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- >=dev-python/automat-0.3.0[${PYTHON_USEDEP}]
- >=dev-python/constantly-15.1.0[${PYTHON_USEDEP}]
+ >=dev-python/automat-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/constantly-15.1[${PYTHON_USEDEP}]
>=dev-python/hyperlink-17.1.1[${PYTHON_USEDEP}]
>=dev-python/incremental-21.3.0[${PYTHON_USEDEP}]
- >=dev-python/pyhamcrest-1.9.0[${PYTHON_USEDEP}]
>=dev-python/typing-extensions-3.6.5[${PYTHON_USEDEP}]
>=dev-python/zope-interface-4.4.2[${PYTHON_USEDEP}]
conch? (
>=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
- dev-python/bcrypt[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.6[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
)
http2? (
- >=dev-python/h2-3.0.0[${PYTHON_USEDEP}]
<dev-python/h2-5.0.0[${PYTHON_USEDEP}]
- >=dev-python/priority-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.0.0[${PYTHON_USEDEP}]
<dev-python/priority-2.0[${PYTHON_USEDEP}]
+ >=dev-python/priority-1.1.0[${PYTHON_USEDEP}]
+ )
+ serial? (
+ >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
)
- serial? ( >=dev-python/pyserial-3.0[${PYTHON_USEDEP}] )
ssl? (
- >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
- dev-python/service_identity[${PYTHON_USEDEP}]
- >=dev-python/idna-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-21.0.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-18.1.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.4[${PYTHON_USEDEP}]
)
"
BDEPEND="
@@ -57,18 +58,19 @@ BDEPEND="
$(python_gen_cond_dep '
>=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
>=dev-python/constantly-15.1.0[${PYTHON_USEDEP}]
- dev-python/cython-test-exception-raiser[${PYTHON_USEDEP}]
- dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/cython-test-exception-raiser-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.4[${PYTHON_USEDEP}]
dev-python/pyasn1[${PYTHON_USEDEP}]
- dev-python/pyserial[${PYTHON_USEDEP}]
+ >=dev-python/pyhamcrest-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
net-misc/openssh
conch? (
- dev-python/bcrypt[${PYTHON_USEDEP}]
- >=dev-python/cryptography-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/bcrypt-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.6[${PYTHON_USEDEP}]
)
ssl? (
- >=dev-python/pyopenssl-16.0.0[${PYTHON_USEDEP}]
- dev-python/service_identity[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-21.0.0[${PYTHON_USEDEP}]
+ >=dev-python/service_identity-18.1.0[${PYTHON_USEDEP}]
)
' python3_{8..10} pypy3)
$(python_gen_cond_dep '