summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-16 23:26:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-17 13:58:31 +0100
commit6a45511ce59cce6ec47f0b608345b21ffa29bbca (patch)
tree3c17024a40d8f246cb0776d00db4b950817f48b1 /dev-qt/qtlocation/qtlocation-5.12.2.ebuild
parentkde-frameworks/plasma: Drop 5.56.1 (diff)
downloadgentoo-6a45511ce59cce6ec47f0b608345b21ffa29bbca.tar.gz
gentoo-6a45511ce59cce6ec47f0b608345b21ffa29bbca.tar.bz2
gentoo-6a45511ce59cce6ec47f0b608345b21ffa29bbca.zip
dev-qt: Add Qt 5.12.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation/qtlocation-5.12.2.ebuild')
-rw-r--r--dev-qt/qtlocation/qtlocation-5.12.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/qtlocation-5.12.2.ebuild b/dev-qt/qtlocation/qtlocation-5.12.2.ebuild
new file mode 100644
index 000000000000..25dc50ab1019
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.12.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}" || die
+ qt5_qmake "${QT_BUILD_DIR}"
+ qt5-build_src_configure
+}