summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 22:35:16 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-11-25 23:40:47 +0100
commita663ab344d4deebd60dc35994eb659579412754d (patch)
treea5bf169a05fe2b3452a93f75cc460c51a61b44c4 /dev-qt/qtlocation
parentdev-db/redis: drop to ~hppa (diff)
downloadgentoo-a663ab344d4deebd60dc35994eb659579412754d.tar.gz
gentoo-a663ab344d4deebd60dc35994eb659579412754d.tar.bz2
gentoo-a663ab344d4deebd60dc35994eb659579412754d.zip
dev-qt: Add Qt 5.15.2
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index bccd0d823c9d..c56e590fa848 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1 +1,2 @@
DIST qtlocation-everywhere-src-5.15.1.tar.xz 6553252 BLAKE2B 493ea55065f03f05db7c65c22f53b96a62b3912a62f3385d393650a96b156e5a5d76dfe5ed3df8eee5ce379c9bbf36a62b6f088dab0519bd14355a7ba956a279 SHA512 b79383b60107bc4d8fcc9b4a087db57597d0b928248806fef9dfeaa8ce3347ce96b388cbce1a7bcaf3287d380f7c269c44e8ec25966112c041aa298313854106
+DIST qtlocation-everywhere-src-5.15.2.tar.xz 6556764 BLAKE2B a322f35ece266fff6428da9090f02c0d5749a4750ff0655ef09695f147d88d667b5917335e44d0f8721cc56f425c171fb11d0f34342aff005327518e9c1d6db8 SHA512 6192922506b3ea354e85431df83c19d7cc9aebb17549c6a1de48f625bf8365ff3db3161080dde254a5fb9199d99c3c5dc8e1533429150be55df96ddb7d6ce16f
diff --git a/dev-qt/qtlocation/qtlocation-5.15.2.ebuild b/dev-qt/qtlocation/qtlocation-5.15.2.ebuild
new file mode 100644
index 000000000000..0772e510f28e
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ dev-libs/icu:=
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtpositioning-${PV}[qml]
+ ~dev-qt/qtsql-${PV}
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtconcurrent-${PV}
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ mkdir -p "${QT5_BUILD_DIR}"/src/location || die
+ qt5_qmake "${QT5_BUILD_DIR}"
+ cp "${S}"/src/location/qtlocation-config.pri "${QT5_BUILD_DIR}"/src/location || die
+ qt5-build_src_configure
+}