summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-16 11:20:20 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-16 20:15:23 -0400
commit4bdf521869a34c0534c644932444435842e8b92a (patch)
tree025f88265fa17a78a77d927d04fa12a8cb2d12b6 /dev-qt
parentnet-misc/cadaver: slightly tweak autoconf-2.72 patch (diff)
downloadgentoo-4bdf521869a34c0534c644932444435842e8b92a.tar.gz
gentoo-4bdf521869a34c0534c644932444435842e8b92a.tar.bz2
gentoo-4bdf521869a34c0534c644932444435842e8b92a.zip
dev-qt/qtwebengine: "improve" build with ninja-1.12 (Qt6)
Most likely more issues, but should hopefully work in most cases until figure out the rest. Users really having issues may want to go back to ~ninja-1.11.1 or even app-alternatives/ninja[samurai] which is known to work for this. (if issues are widespread, may set a ninja upper bound if don't find a proper fix at least before the next Qt bump) Bug: https://bugs.gentoo.org/930107 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-6.7.0-ninja1.12.patch26
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.7.0.ebuild1
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild1
3 files changed, 28 insertions, 0 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-6.7.0-ninja1.12.patch b/dev-qt/qtwebengine/files/qtwebengine-6.7.0-ninja1.12.patch
new file mode 100644
index 000000000000..cd6f6a3cc89d
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-6.7.0-ninja1.12.patch
@@ -0,0 +1,26 @@
+Patch status: pending being looked at upstream
+
+Issue[1][2][3] also exist in chromium itself[4], and unclear
+why this started happening only with ninja-1.12.0 at the moment.
+
+Just a quickfix, likely not correct and seems there may be
+further unresolved race issues[5]. Arguably better to not
+use ninja-1.12.0 for this yet (1.11.1 or samurai are fine).
+
+[1] https://bugs.gentoo.org/930107
+[2] https://bugreports.qt.io/browse/QTBUG-124375
+[3] https://github.com/ninja-build/ninja/issues/2417
+[4] https://bugs.gentoo.org/930112
+[5] https://bugs.gentoo.org/930107#c17
+--- a/src/3rdparty/chromium/content/browser/BUILD.gn
++++ b/src/3rdparty/chromium/content/browser/BUILD.gn
+@@ -198,2 +198,3 @@
+ "//components/services/storage/public/mojom",
++ "//components/spellcheck:buildflags",
+ "//components/sqlite_proto",
+--- a/src/3rdparty/chromium/extensions/browser/api/declarative_net_request/BUILD.gn
++++ b/src/3rdparty/chromium/extensions/browser/api/declarative_net_request/BUILD.gn
+@@ -22,2 +22,3 @@
+ "//content/public/browser",
++ "//components/web_cache/public/mojom",
+ "//extensions/common",
diff --git a/dev-qt/qtwebengine/qtwebengine-6.7.0.ebuild b/dev-qt/qtwebengine/qtwebengine-6.7.0.ebuild
index ce4b07c90f2c..1035ff458cd5 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.7.0.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.7.0.ebuild
@@ -108,6 +108,7 @@ PATCHES=( "${WORKDIR}"/patches/${PN} )
PATCHES+=(
# add extras as needed here, may merge in set if carries across versions
"${FILESDIR}"/${PN}-6.7.0-clang18.patch
+ "${FILESDIR}"/${PN}-6.7.0-ninja1.12.patch
)
python_check_deps() {
diff --git a/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild
index bab0b63fc807..aae8a8cfa848 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.7.9999.ebuild
@@ -108,6 +108,7 @@ PATCHES=( "${WORKDIR}"/patches/${PN} )
PATCHES+=(
# add extras as needed here, may merge in set if carries across versions
"${FILESDIR}"/${PN}-6.7.0-clang18.patch
+ "${FILESDIR}"/${PN}-6.7.0-ninja1.12.patch
)
python_check_deps() {