summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-28 03:02:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-28 08:31:23 -0400
commita249c93ddc74d9ea0a08b7b115d349c1b437d840 (patch)
tree2e14f0fc270af67eadb5456ed5ad7a10e35ba880 /dev-qt
parentdev-qt/qtquicktimeline: add 6.5.3 (diff)
downloadgentoo-a249c93ddc74d9ea0a08b7b115d349c1b437d840.tar.gz
gentoo-a249c93ddc74d9ea0a08b7b115d349c1b437d840.tar.bz2
gentoo-a249c93ddc74d9ea0a08b7b115d349c1b437d840.zip
dev-qt/qtscxml: add 6.5.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 6a8f656b99d3..71185c065b78 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,3 +1,4 @@
DIST qtscxml-everywhere-opensource-src-5.15.10.tar.xz 437404 BLAKE2B e36e866e4c02722f88499cc92bf27d2401f2b89d19fed83915803f6c8a367007fc386df250d11ecd92e5c80713924dd9992608769dbb0a42071f0d928317d935 SHA512 93e2df05da176802a0439ba752f52d1c84d291a2addf9492aaab2099f06efb32d896edd0660711bb2e0b67f7a9ea2c4d31b4ec3366f6230140d3de0056478923
DIST qtscxml-everywhere-src-6.5.2.tar.xz 1163208 BLAKE2B 9e149a82f8f00a7f0c78beb393a87de2dd7b0c61f0168b7f2bb717591d2923b91ef2ebbea211cfe7c724e97a32f74a41537763c828e1e1a3fa16a017b1c73ffa SHA512 fafea704d5e592a31c11f0039336de587353a57d5a69b07d0346fd2906488810d0ed1fc9267a0bf06aeae7f93ae19e150c5734bc969c1e0c7bc4e6215744ac3a
+DIST qtscxml-everywhere-src-6.5.3.tar.xz 1163256 BLAKE2B 7b21e55a13421bad7297e5ea3f6dce6f53981e77388f4fb3ab8025f7beca84255f14f7e67ff43a7617305df4f7c8057c079ecb46e00d9a7061cd38c9e74db43d SHA512 f4aeb2f07a203ef448124b3e988735b46ef38d7800cd60ba3db9c0e0b8a9e9aca44bc07a6d72de2951134200c29d902709a80b52fd030713159c8f1711b60731
DIST qtscxml-everywhere-src-6.6.0-rc.tar.xz 1175036 BLAKE2B 82d6e544c5eb0c80a0a82fb35baa0424e293efb565b95e987245b40efd081023f11fd4bb5416972e72c2c70dbcf98da71a60bda5c658cbfcf81947503a86ea0d SHA512 38c2770d43b7849d6dc121426a569db44c89036f8df497495b81ba680482d3c37984d2adfee2de45ea30cf59656eb44c61413a1e069e8d58ad47c2082d87faf1
diff --git a/dev-qt/qtscxml/qtscxml-6.5.3.ebuild b/dev-qt/qtscxml/qtscxml-6.5.3.ebuild
new file mode 100644
index 000000000000..3baf824212bc
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.5.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}