summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-03 02:39:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-03 03:43:25 -0400
commitdaf905fe1fc41ee90b3fa9851b9fca858fecb789 (patch)
tree9726a9717bef6bc5c3d3f8fe2a5d1a75eddb3458 /dev-qt
parentdev-qt/qtbase: minor style adjustments + add missing bug number (diff)
downloadgentoo-daf905fe1fc41ee90b3fa9851b9fca858fecb789.tar.gz
gentoo-daf905fe1fc41ee90b3fa9851b9fca858fecb789.tar.bz2
gentoo-daf905fe1fc41ee90b3fa9851b9fca858fecb789.zip
dev-qt/qtbase: forward qcontiguouscache patch to <=6.8
Upstreamed but currently is only in dev branch, and unclear if it will make it in 6.7.3 or 6.8.0 before release (-rc is not far for 6.8). Not to forget, add in 6.7.9999 and 6.8.9999 until it fails to apply. Also scrub & add links. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtbase/files/qtbase-6.7.2-qcontiguouscache.patch13
-rw-r--r--dev-qt/qtbase/files/qtbase-6.8.0-qcontiguouscache.patch14
-rw-r--r--dev-qt/qtbase/qtbase-6.7.9999.ebuild1
-rw-r--r--dev-qt/qtbase/qtbase-6.8.9999.ebuild1
4 files changed, 21 insertions, 8 deletions
diff --git a/dev-qt/qtbase/files/qtbase-6.7.2-qcontiguouscache.patch b/dev-qt/qtbase/files/qtbase-6.7.2-qcontiguouscache.patch
index d010222e09da..02219feaf681 100644
--- a/dev-qt/qtbase/files/qtbase-6.7.2-qcontiguouscache.patch
+++ b/dev-qt/qtbase/files/qtbase-6.7.2-qcontiguouscache.patch
@@ -1,11 +1,8 @@
-diff '--color=auto' -ruN qtbase-everywhere-src-6.7.2/src/corelib/tools/qcontiguouscache.h my/src/corelib/tools/qcontiguouscache.h
---- qtbase-everywhere-src-6.7.2/src/corelib/tools/qcontiguouscache.h 2024-05-07 01:06:44.000000000 +0200
-+++ my/src/corelib/tools/qcontiguouscache.h 2024-08-25 18:20:13.958793266 +0200
-@@ -8,6 +8,7 @@
- #include <QtCore/qassert.h>
- #include <QtCore/qtclasshelpermacros.h>
+https://bugs.gentoo.org/938475
+Older version of https://codereview.qt-project.org/c/qt/qtbase/+/585668 for 6.7
+--- a/src/corelib/tools/qcontiguouscache.h
++++ b/src/corelib/tools/qcontiguouscache.h
+@@ -10,2 +10,3 @@
#include <QtCore/qtcoreexports.h>
+#include <QtCore/qglobal.h>
#include <QtCore/qtypeinfo.h>
-
- #include <climits>
diff --git a/dev-qt/qtbase/files/qtbase-6.8.0-qcontiguouscache.patch b/dev-qt/qtbase/files/qtbase-6.8.0-qcontiguouscache.patch
new file mode 100644
index 000000000000..e5f14e0a1c73
--- /dev/null
+++ b/dev-qt/qtbase/files/qtbase-6.8.0-qcontiguouscache.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/938475
+https://codereview.qt-project.org/c/qt/qtbase/+/585668
+From: Sam James <sam@gentoo.org>
+Date: Sun, 25 Aug 2024 17:34:22 +0100
+Subject: [PATCH] QContiguousCache: fix include for qMin
+
+Include `<QtCore/qminmax.h>` for `qMin`. This came up downstream
+in Gentoo at https://bugs.gentoo.org/938475.
+--- a/src/corelib/tools/qcontiguouscache.h
++++ b/src/corelib/tools/qcontiguouscache.h
+@@ -10,2 +10,3 @@
+ #include <QtCore/qtcoreexports.h>
++#include <QtCore/qminmax.h>
+ #include <QtCore/qttypetraits.h>
diff --git a/dev-qt/qtbase/qtbase-6.7.9999.ebuild b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
index b4cd4854a401..85c2de60245c 100644
--- a/dev-qt/qtbase/qtbase-6.7.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.7.9999.ebuild
@@ -145,6 +145,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.5.2-no-symlink-check.patch
"${FILESDIR}"/${PN}-6.6.1-forkfd-childstack-size.patch
"${FILESDIR}"/${PN}-6.6.3-gcc14-avx512fp16.patch
+ "${FILESDIR}"/${PN}-6.7.2-qcontiguouscache.patch
)
src_prepare() {
diff --git a/dev-qt/qtbase/qtbase-6.8.9999.ebuild b/dev-qt/qtbase/qtbase-6.8.9999.ebuild
index 3c595f73638f..0f983d79ae6f 100644
--- a/dev-qt/qtbase/qtbase-6.8.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.8.9999.ebuild
@@ -145,6 +145,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-6.5.2-no-symlink-check.patch
"${FILESDIR}"/${PN}-6.6.1-forkfd-childstack-size.patch
"${FILESDIR}"/${PN}-6.6.3-gcc14-avx512fp16.patch
+ "${FILESDIR}"/${PN}-6.8.0-qcontiguouscache.patch
)
src_prepare() {