summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-15 21:56:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-15 21:56:17 +0200
commitf8bec888645c38ae6dd11860e827b15f50d70cc7 (patch)
treea350fbf1ad3509f3826d67e9a19c96d05d3c5e14 /dev-qt
parentdev-qt/qtwayland: Drop broken patch (diff)
downloadgentoo-f8bec888645c38ae6dd11860e827b15f50d70cc7.tar.gz
gentoo-f8bec888645c38ae6dd11860e827b15f50d70cc7.tar.bz2
gentoo-f8bec888645c38ae6dd11860e827b15f50d70cc7.zip
dev-qt/qtwayland: drop 5.15.10-r1, 5.15.10-r2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwayland/files/qtwayland-5.15.10-send-release-button-event-on-pointer-leave.patch68
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.10-r1.ebuild57
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.10-r2.ebuild57
3 files changed, 0 insertions, 182 deletions
diff --git a/dev-qt/qtwayland/files/qtwayland-5.15.10-send-release-button-event-on-pointer-leave.patch b/dev-qt/qtwayland/files/qtwayland-5.15.10-send-release-button-event-on-pointer-leave.patch
deleted file mode 100644
index 1e949fc32355..000000000000
--- a/dev-qt/qtwayland/files/qtwayland-5.15.10-send-release-button-event-on-pointer-leave.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 90995b07d2d4dbd12b7e527a881bf9d6158e277b Mon Sep 17 00:00:00 2001
-From: Ilya Fedin <fedin-ilja2010@ya.ru>
-Date: Sun, 19 Mar 2023 10:24:59 +0400
-Subject: [PATCH] Client: Send release button event on pointer leave
-
-Fixes: QTBUG-97037
-Pick-to: 6.6 6.5 6.2 5.15
-Change-Id: I151239b276ab5aefe166f5615baf43dab428ce0c
-Reviewed-by: David Edmundson <davidedmundson@kde.org>
-(cherry picked from commit 8235fa65fe033a94e7a44322d3502f25940092ec)
----
- src/client/qwaylandinputdevice.cpp | 9 +++++++--
- src/client/qwaylandinputdevice_p.h | 1 +
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/src/client/qwaylandinputdevice.cpp b/src/client/qwaylandinputdevice.cpp
-index bc05583a..e562c7a7 100644
---- a/src/client/qwaylandinputdevice.cpp
-+++ b/src/client/qwaylandinputdevice.cpp
-@@ -688,8 +688,8 @@ public:
-
- void QWaylandInputDevice::Pointer::pointer_leave(uint32_t time, struct wl_surface *surface)
- {
-+ releaseButtons();
- invalidateFocus();
-- mButtons = Qt::NoButton;
-
- mParent->mTime = time;
-
-@@ -804,6 +804,8 @@ void QWaylandInputDevice::Pointer::pointer_button(uint32_t serial, uint32_t time
- default: return; // invalid button number (as far as Qt is concerned)
- }
-
-+ mLastButton = qt_button;
-+
- if (state)
- mButtons |= qt_button;
- else
-@@ -842,10 +844,13 @@ void QWaylandInputDevice::Pointer::invalidateFocus()
-
- void QWaylandInputDevice::Pointer::releaseButtons()
- {
-+ if (mButtons == Qt::NoButton)
-+ return;
-+
- mButtons = Qt::NoButton;
-
- if (auto *window = focusWindow()) {
-- ReleaseEvent e(focusWindow(), mParent->mTime, mSurfacePos, mGlobalPos, mButtons, Qt::NoButton, mParent->modifiers());
-+ ReleaseEvent e(focusWindow(), mParent->mTime, mSurfacePos, mGlobalPos, mButtons, mLastButton, mParent->modifiers());
- window->handleMouse(mParent, e);
- }
- }
-diff --git a/src/client/qwaylandinputdevice_p.h b/src/client/qwaylandinputdevice_p.h
-index 5795f138..bafe3db2 100644
---- a/src/client/qwaylandinputdevice_p.h
-+++ b/src/client/qwaylandinputdevice_p.h
-@@ -346,6 +346,7 @@ public:
- QPointF mSurfacePos;
- QPointF mGlobalPos;
- Qt::MouseButtons mButtons = Qt::NoButton;
-+ Qt::MouseButton mLastButton = Qt::NoButton;
- #if QT_CONFIG(cursor)
- wl_buffer *mCursorBuffer = nullptr;
- Qt::CursorShape mCursorShape = Qt::BitmapCursor;
---
-2.41.0
-
diff --git a/dev-qt/qtwayland/qtwayland-5.15.10-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.15.10-r1.ebuild
deleted file mode 100644
index d724c80f99ba..000000000000
--- a/dev-qt/qtwayland/qtwayland-5.15.10-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} != *9999* ]]; then
- QT5_KDEPATCHSET_REV=1
- KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
-fi
-
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-SLOT=5/${QT5_PV} # bug 815646
-IUSE="vulkan X"
-
-DEPEND="
- dev-libs/wayland
- =dev-qt/qtcore-${QT5_PV}*:5=
- =dev-qt/qtdeclarative-${QT5_PV}*:5=
- =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
- media-libs/libglvnd
- vulkan? ( dev-util/vulkan-headers )
- X? (
- =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-util/wayland-scanner"
-
-PATCHES=(
- # QTBUG-97037, pending upstream:
- # https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/71
- "${FILESDIR}/${PN}-5.15.9-fix-mouse-stuck-in-pressed-state-after-DnD.patch"
- "${FILESDIR}/${P}-send-release-button-event-on-pointer-leave.patch"
- # bug #910315, pending upstream:
- # https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/73
- "${FILESDIR}/${P}-Destroy-frame-queue-before-display.patch"
-)
-
-src_configure() {
- local myqmakeargs=(
- --
- $(qt_use vulkan feature-wayland-vulkan-server-buffer)
- $(qt_use X feature-xcomposite-egl)
- $(qt_use X feature-xcomposite-glx)
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
- rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
-}
diff --git a/dev-qt/qtwayland/qtwayland-5.15.10-r2.ebuild b/dev-qt/qtwayland/qtwayland-5.15.10-r2.ebuild
deleted file mode 100644
index 7e7e512c763a..000000000000
--- a/dev-qt/qtwayland/qtwayland-5.15.10-r2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-if [[ ${PV} != *9999* ]]; then
- QT5_KDEPATCHSET_REV=2
- KEYWORDS="~amd64 arm arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-
-SLOT=5/${QT5_PV} # bug 815646
-IUSE="vulkan X"
-
-DEPEND="
- dev-libs/wayland
- =dev-qt/qtcore-${QT5_PV}*:5=
- =dev-qt/qtdeclarative-${QT5_PV}*:5=
- =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
- media-libs/libglvnd
- vulkan? ( dev-util/vulkan-headers )
- X? (
- =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-util/wayland-scanner"
-
-PATCHES=(
- # QTBUG-97037, pending upstream:
- # https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/71
- "${FILESDIR}/${PN}-5.15.9-fix-mouse-stuck-in-pressed-state-after-DnD.patch"
- "${FILESDIR}/${P}-send-release-button-event-on-pointer-leave.patch"
- # QTBUG-95434, pending/approved upstream:
- # https://invent.kde.org/qt/qt/qtwayland/-/merge_requests/79
- "${FILESDIR}/${P}-QTBUG-95434-convert-cursor-bitmap.patch"
-)
-
-src_configure() {
- local myqmakeargs=(
- --
- $(qt_use vulkan feature-wayland-vulkan-server-buffer)
- $(qt_use X feature-xcomposite-egl)
- $(qt_use X feature-xcomposite-glx)
- )
- qt5-build_src_configure
-}
-
-src_install() {
- qt5-build_src_install
- rm "${D}${QT5_BINDIR}"/qtwaylandscanner || die
-}