summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 21:18:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 21:22:08 +0200
commitafa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730 (patch)
treea425bd85cd2801bb606fd66d6c0f216b9a7fd0af /dev-ros/filters/files
parentdev-ros/control_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-afa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730.tar.gz
gentoo-afa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730.tar.bz2
gentoo-afa5c8cb58bbb2d4b5024a9b24c8a1880a7fa730.zip
dev-ros/filters: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/filters/files')
-rw-r--r--dev-ros/filters/files/tests.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/filters/files/tests.patch b/dev-ros/filters/files/tests.patch
new file mode 100644
index 000000000000..ee1f8628c76b
--- /dev/null
+++ b/dev-ros/filters/files/tests.patch
@@ -0,0 +1,23 @@
+Upstream status: Merged.
+https://github.com/ros/filters/commit/2607c82034cdfbf96fe372c9637b0133b6ba6970
+
+Index: filters-1.7.4/CMakeLists.txt
+===================================================================
+--- filters-1.7.4.orig/CMakeLists.txt
++++ filters-1.7.4/CMakeLists.txt
+@@ -40,6 +40,7 @@ target_link_libraries(median ${catkin_LI
+ add_library(transfer_function src/transfer_function.cpp)
+ target_link_libraries(transfer_function ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+
++if(CATKIN_ENABLE_TESTING)
+ # Test median filter
+ add_executable(median_test EXCLUDE_FROM_ALL test/test_median.cpp )
+ target_link_libraries(median_test median ${catkin_LIBRARIES} ${Boost_LIBRARIES} ${GTEST_LIBRARIES})
+@@ -67,6 +68,7 @@ add_rostest(test/test_chain.launch)
+
+ # Test realtime safe buffer class
+ catkin_add_gtest(realtime_buffer_test EXCLUDE_FROM_ALL test/test_realtime_circular_buffer.cpp)
++endif()
+
+ ##############################################################################
+ # Install