summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-12 20:31:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-12 21:08:36 +0200
commitba328f22b179f00dfb9fe852e1cc9475f1061bed (patch)
tree9b9f7e3884149fdbf1723b3c8090dbb2bb93ba2b /dev-ros/global_planner/global_planner-1.17.1.ebuild
parentdev-ros/fake_localization: Bump to 1.17.1. (diff)
downloadgentoo-ba328f22b179f00dfb9fe852e1cc9475f1061bed.tar.gz
gentoo-ba328f22b179f00dfb9fe852e1cc9475f1061bed.tar.bz2
gentoo-ba328f22b179f00dfb9fe852e1cc9475f1061bed.zip
dev-ros/global_planner: Bump to 1.17.1.
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/global_planner/global_planner-1.17.1.ebuild')
-rw-r--r--dev-ros/global_planner/global_planner-1.17.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/global_planner/global_planner-1.17.1.ebuild b/dev-ros/global_planner/global_planner-1.17.1.ebuild
new file mode 100644
index 000000000000..8d1a9dbe0d24
--- /dev/null
+++ b/dev-ros/global_planner/global_planner-1.17.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Path planner library and node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/costmap_2d-1.16
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/nav_core
+ dev-ros/navfn
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf2_ros
+
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+
+ dev-ros/angles
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"