summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-20 21:06:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-20 21:35:23 +0100
commitd1757bed163c676f692b0e50e234804c65e0758e (patch)
tree6671a87f3ae967bce433af4ec74570bda07ccaad /dev-ros/hector_imu_tools/hector_imu_tools-0.5.1.ebuild
parentdev-ros/hector_geotiff_plugins: Bump to 0.5.1. (diff)
downloadgentoo-d1757bed163c676f692b0e50e234804c65e0758e.tar.gz
gentoo-d1757bed163c676f692b0e50e234804c65e0758e.tar.bz2
gentoo-d1757bed163c676f692b0e50e234804c65e0758e.zip
dev-ros/hector_imu_tools: Bump to 0.5.1.
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_imu_tools/hector_imu_tools-0.5.1.ebuild')
-rw-r--r--dev-ros/hector_imu_tools/hector_imu_tools-0.5.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/hector_imu_tools/hector_imu_tools-0.5.1.ebuild b/dev-ros/hector_imu_tools/hector_imu_tools-0.5.1.ebuild
new file mode 100644
index 000000000000..45f66eda01ab
--- /dev/null
+++ b/dev-ros/hector_imu_tools/hector_imu_tools-0.5.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for processing IMU messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"