summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 16:59:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 18:30:44 +0200
commit09771221eaf791799a5d74397a6abf5a08a88f73 (patch)
tree9face6d14d5e149427f85c28191f71ebdf488a78 /dev-ros/hector_pose_estimation
parentdev-ros/hector_pose_estimation_core: bump eapi (diff)
downloadgentoo-09771221eaf791799a5d74397a6abf5a08a88f73.tar.gz
gentoo-09771221eaf791799a5d74397a6abf5a08a88f73.tar.bz2
gentoo-09771221eaf791799a5d74397a6abf5a08a88f73.zip
dev-ros/hector_pose_estimation: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/hector_pose_estimation')
-rw-r--r--dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch4
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild14
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild13
3 files changed, 16 insertions, 15 deletions
diff --git a/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
index a226c40e9fce..59349bbfe02f 100644
--- a/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
+++ b/dev-ros/hector_pose_estimation/files/hector_pose_estimation-0.3.0-pluginlib.patch
@@ -9,8 +9,8 @@ Subject: [PATCH] update to use non deprecated pluginlib macro
diff --git a/hector_pose_estimation/src/pose_estimation_nodelet.cpp b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
index 7da3ca6..97ba5b0 100644
---- a/hector_pose_estimation/src/pose_estimation_nodelet.cpp
-+++ b/hector_pose_estimation/src/pose_estimation_nodelet.cpp
+--- hector_pose_estimation/src/pose_estimation_nodelet.cpp
++++ hector_pose_estimation/src/pose_estimation_nodelet.cpp
@@ -55,4 +55,4 @@ class PoseEstimationNodelet : public PoseEstimationNode, public nodelet::Nodelet
} // namespace hector_pose_estimation
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
index 284a8883bbab..783aaeb2225c 100644
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-0.3.0-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
@@ -16,15 +16,15 @@ IUSE=""
RDEPEND="
dev-ros/hector_pose_estimation_core
dev-ros/nodelet
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
dev-ros/message_filters
dev-libs/boost:=
dev-libs/console_bridge:=
"
# dev-ros/hector_timing
-DEPEND="${RDEPEND}"
-
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
PATCHES=( "${FILESDIR}"/${PN}-0.3.0-pluginlib.patch )
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
index 7cc3dd4e6490..8bfff8077200 100644
--- a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
@@ -16,13 +16,14 @@ IUSE=""
RDEPEND="
dev-ros/hector_pose_estimation_core
dev-ros/nodelet
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
dev-ros/message_filters
dev-libs/boost:=
dev-libs/console_bridge:=
"
# dev-ros/hector_timing
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"