summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-06 16:49:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-06 20:23:27 +0100
commit5c9b7b5efacd4f037fa15f864db5578430968eb7 (patch)
tree60c1ca50c748ceacc766c26c38c4618d866d2342 /dev-ros/ros_environment/ros_environment-9999.ebuild
parentdev-util/catkin: bump to 0.7.11 (diff)
downloadgentoo-5c9b7b5efacd4f037fa15f864db5578430968eb7.tar.gz
gentoo-5c9b7b5efacd4f037fa15f864db5578430968eb7.tar.bz2
gentoo-5c9b7b5efacd4f037fa15f864db5578430968eb7.zip
dev-ros/ros_environment: initial import
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/ros_environment/ros_environment-9999.ebuild')
-rw-r--r--dev-ros/ros_environment/ros_environment-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/ros_environment/ros_environment-9999.ebuild b/dev-ros/ros_environment/ros_environment-9999.ebuild
new file mode 100644
index 000000000000..14906c3050db
--- /dev/null
+++ b/dev-ros/ros_environment/ros_environment-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_environment"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS environment variables"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!!<dev-ros/roslib-1.14.3"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkinprefixpath.patch" )
+
+src_configure() {
+ export ROS_DISTRO="Gentoo"
+ export ROS_DISTRO_OVERRIDE="Gentoo"
+ ros-catkin_src_configure
+}